2GB RAM upgrade "eee PC 900" - Black Screen Problem

Discussion in 'PC Hardware' started by itsmemario1, Jul 18, 2015.

  1. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    264
    23
    10
    #1 itsmemario1, Jul 18, 2015
    Last edited: Jul 18, 2015
    Hi,

    I upgraded my "eee PC 900" to 2GB RAM, but as many other ASUS Laptops, the screen stays black when switching it on.

    Various solutions (disabling Quick Boot, reinstalling Graphics Driver, installing fresh OS) did not help.

    Its a "NANYA 2GB.2Rx8.PC2-5300S-555-13-F1.667" and I was hoping for someone to direct me towards a working one. :tasty:
     
  2. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,707
    3,064
    300
    You do not say what os you have installed perhaps it cannot handle default screen resolution if it was not xp.
     
  3. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    264
    23
    10
    #3 itsmemario1, Jul 18, 2015
    Last edited: Jul 19, 2015
    (OP)
    It was XP before and now uses Win 7 Tiny.

    The "old" ASUS intel gfx drivers work fine in Win 7 Tiny.

    Thats why I wrote that I tried all "solutions" by now. :weep:

    And I meant "screen stays black on switching it on". It doesnt boot with the 2GB RAM. But I have seen eee PC 900s working with 2GB of RAM.
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,354
    1,446
    180
    its the ram.. not the os.
    look at others working modules timings.
     
  5. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,488
    1,327
    60
    #5 QuantumBug, Jul 18, 2015
    Last edited: Jul 18, 2015
    I agree,

    Some machines won't accept memory even if it fits. So instead of underclocking the speed it just won't work.

    Any beeps or lights flashing to represent an error? Does your old memory work?

    Also, plug in the new memory, remove the battery and DC power, hold the power button for 30 seconds, plug in the POWER CABLE ONLY and attempt to power the machine. This has worked for me a few times, not many though.

    Regards, The Dev.

    EDIT: Have you updated or flashed you BIOS recently. I saw your other post.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    264
    23
    10
  7. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,795
    6,762
    270
    if your system can in fact take 2gb, then go into your bios with the old ram and set it to "Fail safe" default, or whatever word they use to reset the bios to default settings shut it down remove the old memory insert the new and try again.
     
  8. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    264
    23
    10
    Qimoda 2GB "PC2-4200-444-12" works :)