4750G Stuck on BIOS Splash Screen. Help :(

Discussion in 'BIOS Mods' started by sneakablez, Sep 5, 2015.

  1. sneakablez

    sneakablez MDL Novice

    Sep 4, 2015
    2
    0
    0
    Hi Guys,

    I'm having a problem on my notebook while I was upgrading to Windows 10. During upgrade it was installing fine but it wasn't able to boot back into windows as it was first stuck on windws 10 loading screen and it was stuck there for an hour so I turned it off and it show reverting back to old windows but ti was stuck there again so I turned it off and it was no longer able to get pass the bios acer splash screen and it will not load anymore. I thought it was a hard drive but it is not.


    Not working:
    - Bios loading bar at the bottom show loading up to 75% of the bar but stops there
    - Connot enter bios menu even so. No F2 t let me enter setup. I guess coz stuck on 75% loading.
    - I cannot see post messages since it's seems always hidden unless set inside the bios.

    Here's what I already did:
    - I have removed everything down to the just the notebook motherboard w/ mem along + screen + power switch. No other component attached to the board(like hdd, bluetooth, speeker, usb/port, network card)
    - Reset CMOS I removed the battery, not using a battery when troubleshooting.
    - Reseated the cpu and cleaned heatsink/chips w/ repaste(I just did since I'm running out of ideas)
    - swapped the ram modules to different slots and used a new memory module from my other notebook
    - I've also tried Crisis Recover to try reflashing the BIOS as I am already running out of ideas but nothing happens with(FN+ESC, just black screen). I've already tried many options about this trick but just nothing o_O

    Even though I did all that above still the same problem. Stuck on Acer logo bios splash screen. I wish I can see the POST messages but all I see is big Acer logo and loading bar that doesn't complete.

    Working:
    - Even though it's stuck on bios acer splash screen FN + brightness works, including the other FN functions like keyboard off, display on off etc....
    - Ctrl + Alt + Del works even thought it's stuck

    Trying:
    - I'm trying the Recover method mentioned on the service manual below . Assuming that's bit different on wincrisis which is using different set of files but
    How do i find the efi folder, pflash.efi and crisisrecovery.efi? :g:


    Well sometimes I'm thinking that Windows 10 upgrade destroyed my laptop or I guess it was pure coincidence. I'm wondering what's the problem here to be honest. Bios corrupted? Not really, it's impossible windows upgrade can do that since slash and fn keys are still working. CPU/Mem problem? But's it's booting just stuck.
    Was perfectly working without any probs or overheating problems since I often clean it every 5-6 months and use IC diamond for the past 4yrs.

    Any laptop technician opinion here is gladly appreciated :)
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    #2 LatinMcG, Sep 5, 2015
    Last edited: Sep 5, 2015
  3. sneakablez

    sneakablez MDL Novice

    Sep 4, 2015
    2
    0
    0
    thanks for the reply... :)

    But I cannot find any J1 on the board near the mem to short. I've checkout what's J1 and read its a jumper reset for bios password on some Acer notebook. It said it's the two short dots on the memslot so I tried anyway but nothing. For this unit according to the manualslib.com/manual/232524/Acer-Aspire-4350.html?page=104#manual is G2201 but I don't remember using any bios password on my unit. Anyhow I've also tried shorting this jumper on G2201 and G2101 but just nothing.
    Still the same issue :weep:

    I've tried reseating the ram on both slots and also used other ram but still the same issue... :(

    :g::weep::confused::(