access Denied on alot of file Operations.

Discussion in 'Windows 8' started by CaelThunderwing, Apr 2, 2014.

  1. CaelThunderwing

    CaelThunderwing MDL Novice

    Feb 27, 2012
    9
    0
    0
    i was going crazy outta my skull by that anytime i ran certain game installers or Mod patchers (the popular FF7 Mod instaler "Bootleg" [not to be confuse dfor pirate FF7 installers.) would encounter alot of Access Denied error swhen trying to Write to c:\games\FF7, or the Anxious Heart Soundtrack installer would outright be blocked allaround (opening would get a popup saying "Access Denied" (and in file properties it'd say the typical "warning file came from another computer and maybe dangerous." w/ the option to unblock only that everytime i'd click unblock . its instantly reblocked.

    hell the folder the Game converter (which converts the Steam version of the game to the 1998 orginal PC vers for modding) makes "Games\FF7" both folders get set Read only and Remain Read Only but content inside isnt.

    for now im dualbooting between 7 & 8 so i can get some use out of my system till i can get help solving this.

    vers Used: Windows 8.1 Pro VLK from release thread
     
  2. blackdeathzc

    blackdeathzc MDL Novice

    Jul 21, 2009
    6
    1
    0
    check owner of folder. must be wrong security settings
     
  3. CaelThunderwing

    CaelThunderwing MDL Novice

    Feb 27, 2012
    9
    0
    0
    well first things i tried were running the patcher thru a command prompt window as admin that solved the GameConverter issues. but the issue with Anxious Heart's Soundtrack Installer it didnt help :/

    as for the folder issues it was the first thing i tried (taking ownership) and it still didnt help :/
     
  4. jabbawok

    jabbawok MDL Novice

    Mar 18, 2009
    34
    13
    0
    After taking ownership, did you give yourself the required permissions?
     
  5. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,365
    210
    #5 murphy78, Apr 3, 2014
    Last edited by a moderator: Apr 20, 2017
    takeown by itself doesn't give you the rights. you need to use icacls as well.

    the takeown.reg right click mod does all this for you:

    Code:
    Windows Registry Editor Version 5.00
    
    
    [HKEY_CLASSES_ROOT\*\shell\runas]
    @="Take Ownership"
    "NoWorkingDirectory"=""
    
    
    [HKEY_CLASSES_ROOT\*\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas]
    @="Take Ownership"
    "NoWorkingDirectory"=""
    
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...