acer spin 5 515-51N bios bricked

Discussion in 'BIOS Mods' started by btrex2100, Apr 17, 2019.

  1. btrex2100

    btrex2100 MDL Novice

    Apr 2, 2014
    8
    0
    0
    Hello,

    Would like to ask how to recover acer spin 5 515-51n's bios, as i had bricked it, was a victim of windows update which lead to acer boot logo hang and loop, which lead to me to experiment on said laptop which i removed the m2 ssd drive but still the same, so i pull out the laptop's battery and also the rtc battery, then i powered on which ended up on black screen and keyboard led only looping for every 2 secs not until you pull the power.

    i tried to use the <fn> + <esc> with a fat32 4gb flash drive and its bios from acer's support site named as BuzzKBL.fd as some forum had said to use UEFItool to search for its .fd filename to be put on the flash.

    so, i pressed the keys powered it up, the reads the flash but never continues as after reading the flash the power led flashes quickly 3x then powers down. then nothing happens. need assistance for this. thanks in advance.
     
  2. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,688
    1,391
    90
    Never seen a bricked bios after windows update. What did you do exactly ?
     
  3. btrex2100

    btrex2100 MDL Novice

    Apr 2, 2014
    8
    0
    0
    #3 btrex2100, Apr 18, 2019
    Last edited: Apr 18, 2019
    (OP)
    my bad for jumping into conclusions, also, this would be a long wall of text but i'll try to make it short

    -was an arab customer's computer he bought via online, i suspect unofficial third party reseller/retailer and can't RMA it or not being entertained or might be being expensively charged.
    -said laptop was only at acer's boot logo with the circling going around, hangs and boots again into eternal loop.
    -he said he brought it to repairshops but they return it to him with no luck saying there's a problem inside which they advised to RMA it.
    -inevitably came here to our shop and asked to do anything to get it fixed regardless of the warranty
    -we are able to access bios via f2 or access the boot menu and windows recovery which would end into acer's boot logo and boot loops again.
    -i tore down the laptop because all the boot would result only to the loop even though it's a gpt/fat32 flash bootable windows 10 untouched/esd image <came from this forum>
    -disconnected the built-in battery via its cable, pulled out the m2 ssd hard drive and took off the cmos/rtc battery and powers it on
    -resulted to black screen/no display, keyboard light and power led cycles for 2 secs and turns off again, and loops again and again.
    -my gist was, why would the customer had problems if it was functioning well before all of this? must be that WU is pushing updates and includes the bios update due to the intel's security vulnerability of meltdown and spectre, but instead of finishing the update he turned the machine off or put it to sleep, this is just my suspicions.

    edit:
    my bad, i tried to look for solutions but only made it worst due to my mistake, i was hoping here that someone would be able to point me to the right bios image or the right name of the .fd file that i should put inside the fat32 usb drive for bios recovery. thanks in advance
     
  4. Guest00k

    Guest00k MDL Novice

    Aug 26, 2019
    6
    1
    0
    Hi!


    I have exactly the same problem as you on a SPIN 5 515. How did you solve the problem?

    I tried every possible name to try to recover the bios (fn + esc). the key flashes once (1second) and the pc goes off to restart but still black screen and keyboard backlight on...
     
  5. btrex2100

    btrex2100 MDL Novice

    Apr 2, 2014
    8
    0
    0
    Hi,

    Unfortunately, I took it to another shop and had them reprogram the firmware/bios, by taking it off the board, them using an interface plugging it to a usb and there. it's done. paid them 100SAR. Good luck on your endeavors and have a nice day.