Acer V5-121 Upgrade BIOS to v2 and Unlock Disabled Menus for SVM

Discussion in 'BIOS Mods' started by jrgalang, Mar 6, 2014.

  1. jrgalang

    jrgalang MDL Novice

    Mar 4, 2014
    2
    0
    0
    #1 jrgalang, Mar 6, 2014
    Last edited: Mar 6, 2014
    All credits to their respective contributors (BDMaster, Serg008, and Tito you awesome folks!), I'm just starting this thread to share the challenges that I had while I tried to upgrade my BIOS so that I can have SVM enabled as I need VirtualBox and Kali to work on this rather portable unit.

    There's a similar thread but for a different model, V5-122, which was difficult to get to work with as merely even getting Linux to boot in UEFI is impossible for those still on v1.0.x (I was on v1.0.8 when I did this). I was hoping there'd be a chance there's a flash approach given that it will take a couple of reverse-engineering to retrieve the ROM from the executable that Acer provides.

    Before proceeding though, be advised that the usual disclaimer applies. I am merely sharing and consolidating all the information that I was able to gather here, and there's that risk of bricking your device should you decide to continue.

    So, let's get started!

    PRE-REQUISITE: You will need a Hex Editor. For me I used HxD, mainly because it's free and is enough to do the trick. It also backs up the original file while you're taking a stab at making updates to the .exe file.

    1. Tito posted an excellent article in his blog ( catchtito.blogspot.com/2013/05/how-to-update-to-2x-bios-from-1x-bios.html ). The key information that you need to arm yourself with is:

    2. As of this writing, the only v2.x BIOS version available on Acer's support site is v2.12. If you try opening the executable and change that parameter while you're in a v1.x BIOS, it will still not work. When I tried using Windows 8 64-bit, I'm greeted by a new error message "secure BIOS not compatible for this version" or something to that extent. My guess is that it's intentional, but there's still hope - you just have to flash an earlier BIOS version, v2.10.

    I've managed to scout a copy of v2.10 ( drivers.windows8downloads.com/win8-acer-aspire-v5-121-bios-2-10-for-windows-8-64-bit-bergq/ ). You may be able to find it elsewhere, but this worked for me.

    3. Extract the executable from the archive and open it using a Hex editor. Apply the change that Tito mentioned in Step 1 (just change 1 to 0 for DisableSecureCapsuleFlash)

    4. Save the executable and run it. It should now allow you to flash to v2.10. Wait for the BIOS to flash and for your laptop to restart.

    5. Once your laptop restarts, it *might* inform you that there's no bootable device available. Fret not, just restart your laptop again (you may hit CTRL+ALT+DEL for this) and go to the setup menu (F2).

    6. In the BIOS Setup Menu, go to Boot tab and change the boot mode from UEFI to Legacy BIOS for now. Save changes and restart. It should now boot back to your OS.

    7. Once you've logged in to your OS, extract v2.12 this time around and run it as well. The flash for this version will occur after a system restart.

    8. After a successful flash, you *might* arrive to the "no bootable device available" issue again. Just repeat Step 6.

    9. Once you manage to boot back to your OS for another round, check BDMaster's response to outlaw4ever ( forums.mydigitallife.net/threads/7033-Insyde-bios-mod-requests?p=879069&viewfull=1#post879069 ), which contains the download link for the modified v2.12 BIOS for this model with SLIC and the Advanced Menu enabled. If you're too lazy to open the post, here's the direct link: rghost.net/52670052

    10. Follow the steps included in the text file stored in the archive. Note that you will need a USB Flash Disk AND that all contents will be removed. Once you're able to create the recovery disk, shutdown your laptop.

    11. There's a lot of disassembly involved in the original steps for the modified BIOS to run an emergency flash... so to minimize disassembling parts, here's the bare minimum that you need to do to make it happen:

    • While your computer is turned off, remove the power cord / charger (if it's still attached)
    • Insert the USB Flash Disk to the USB port (for me the USB 3.0 port worked, it's the one at the left and is color-coded BLUE for reference)
    • Hold the FN + ESC keys simultaneously
    • While still holding FN + ESC, press the power button
    • Once the power LED is lit, let go of the power button while still holding on FN + ESC until you see the LED of your USB Flash Disk blinking or hear the CPU fan run
    • It will take a while (mine took ~5 minutes) but provided you followed all the steps, your laptop should restart with the modded BIOS

    And that's it! You might end up with the "no bootable device available" again but you already know the drill (Hint: Step 6!). You should now be able to see the Advanced menu with CPU configuration where you can enable virtualization.

    Based from the options available, it actually makes sense as to why Acer may have chosen to have this menu hidden, as I ended up not getting the laptop to POST after changing other settings beyond SVM. It's easy though in case you encounter this as all you need to do is repeat the emergency flash process using the modded BIOS. Just sharing it here so everyone's aware.

    It took a while but well worth-it. For a budget laptop it sure is holding up, and I managed to run Kali smoothly with it finally.

    Post here your experience as well and again, thanks to those who contributed to providing their insight and share the files to make this happen!


    PS Apologies if the links have their protocols removed / not hyperlinked. Evidently I'm just new, hence I'm not yet allowed to have links in my posts.