Adding NVIDIA SLI support to GA-EX58-DS4 BIOS

Discussion in 'BIOS Mods' started by patriekvg, Jun 7, 2013.

  1. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    #1 patriekvg, Jun 7, 2013
    Last edited: Jun 7, 2013
    Hi,

    Gigabyte once decided to add SLI support to all X58 boards after all ...except the EX58-DS4 which was already EOL. =(
    I found out about this, after I bought myself a second GTX660 Ti.

    I read this SLI support is in fact only a certain string in the BIOS, just like all SLIC mods are done here. So now I am hoping that someone can help me doing this mod.

    Manufacturer: GIGABYTE
    Motherboard Model: GA-EX58-DS4
    BIOS revision: F11
    BIOS type: Award
    Bios Download Link: www[DOT]gigabyte.com/products/product-page.aspx?pid=2959#bios
    I have added an export from the ACPI table from my current BIOS version F6, which has an SLIC mod, but I dont know if its relevant!
     

    Attached Files:

  2. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    Is there really not anyone who can help me with this? :(
     
  3. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    Thanks for your reply, but that seems to be just an SLIC mod (not NVIDIA SLI).
     
  5. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    O really!?! You just made me a very happy man! :D
    So you modified this yourself? Do you have this board yourself too and using it?

    Thank you VERY much!
     
  7. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Yap, using Award Tool. But I don't have it.

    You still need a patched HAL or modified driver to get it working. Please post a screenshot of AIDA64 (Motherboard -> ACPI -> DSDT)

    Btw, is the SLIC mod successful??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    I'm sorry, what is a HAL? With modified driver you mean the GeForce driver?

    The modified BIOS I had with SLIC mod worked fine yes. But actually I dont care much about such a mod, because the Loader by Daz works so well.
     
  9. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    I see... i've read some of it quickly (I am at work), but will do more effort tonight.

    How do I get the modified HAL and / or driver? And does your BIOS require some regedit in Windows?

    Thanks again man! If this works, it would save me an upgrade. My i7-920 @ 3,9GHz is still sufficient for games.
     
  11. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    There are dedicated forums on this topic. Search a bit after finishing work :)

    Noop, the modded bios doesn't require any registry changes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    Okey thanks Tito. I've read the forum thread you linked to, learned a bit about the requirements to get SLI working. So I need this modified BIOS you created and a modified HAL (which is a .dll file in Windows if I'm correct) OR a modified GeForce driver. The link in the thread to these is dead. I've also did some searches for simular threads on this forum, but still can't find it?

    Also a few questions about the BIOS. I can simply install this using QFlash? And, I assume you added the SLIC 2.1 mod, for Windows 7, right? I will try flashing it in a few minutes - thank god I have DualBIOS, otherwise I wouldn't dare.
     
  13. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Flash from DOS using SPIFLASH is recommended.

    Yah, this mod also contains SLIC 2.1.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    Alright! Succesfull BIOS flash (using FLASHSPI). I have not tweaked my BIOS settings yet, but I will go and install AIDA now.
    One thing I saw; Windows 7 says I'm not legit now. But I'll try and fix that later.
     
  15. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Please post a screenshot of SLIC Toolkit Advanced tab.

    :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    Screenshot:
    screen.jpg
     
  17. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Hmm... the SLIC mod isn't working. :g:

    Anyway, post the screenshot of AIDA64.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    #18 patriekvg, Jun 13, 2013
    Last edited: Jun 13, 2013
    (OP)
    Screenshot AIDA:
    screen2.jpg
    Translated: it says SLI cert is not available :(

    Like I said, I don't care much about the SLIC mod - a Loader should work fine. And I will do a fresh Windows install anyways.
    What I really want is getting SLI up and running!

    Hope you can still help me!
     
  19. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,672
    15,623
    340
    Wait wait wait...

    Have you installed my mod or the original bios from Gigabyte?? First flash official one then (after reboot) my mod.

    (Hint: Try to rename the modded bios as SLIC.BIN or something shorter in length)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. patriekvg

    patriekvg MDL Novice

    Aug 18, 2009
    25
    4
    0
    No I flashed yours right away. So okey, I will flash it again with the official one. And then again with yours.