After bios update new device comes from nowhere

Discussion in 'Windows 7' started by osmoTR, Feb 28, 2011.

  1. osmoTR

    osmoTR MDL Novice

    May 3, 2009
    15
    1
    0
    I have Acer Aspire 5315 with win7 ultimate sp1

    i flashed with modded bios slic 2.1 after then flash in device manager a unknown device shows

    device details ACPI\ENE0100 "ENE CIR RECEIVER"

    so i googled for device and i founded a driver then i installed it shows in device manager works fine and windows ehome stuff
    anyway this notebook doesn't have ir recevier i googled for and acer aspire 5720 model has ir recevier

    these models share has some bios and both same mainboard called icl50 acadia something like

    after bios flash in bios option ir recevier enabled so how i can disable damn thing

    sorry about my poor english
     
  2. subpsyke

    subpsyke MDL Junior Member

    Aug 14, 2009
    75
    12
    0
    Certain BIOSes are modded using a RWEverything report (i.e., a dump of ACPI data) from an unmodded system. It's possible that the BIOS you're using was modded on another laptop model (such as the 5720 you mentioned). If the ACPI tables are different, it may cause some kind of conflict or problem for you (such as phantom devices recognised).

    If that's the case, then I recommend that you:
    1. Revert to the unmodded, original BIOS version (important).
    2. Mod the same original BIOS using Andy's tool yourself.

    This is the best way to guarantee a proper working BIOS. You should be modding the BIOS yourself, anyway.
     
  3. osmoTR

    osmoTR MDL Novice

    May 3, 2009
    15
    1
    0
    i made myself after same issue still continue

    change has been made in DMI table my normal dmi data "board product name: Acadia" but after bios update changed to product name :eMachines
    i dumped my bios and i injected slic to my dumped own bios with my laptop specific variable dmi data
    slic injection well done but didn't recornized slic table non table found

    i reverted own dumped unmodded after i take rweverything report nothing work

    flash with /all option remove all variable dmi data but non /all option no slic
    i don't know what i have to do i am confused
     
  4. silas

    silas MDL Novice

    Jul 2, 2011
    1
    0
    0
    #4 silas, Jul 5, 2011
    Last edited: Jul 5, 2011
    Hi

    I have same issue (it's eMachine now), but in my case I do not have copy of my original bios - I didn't make a backup. I have a ACER ASPIRE 5315-201G12 (201G12Mi) (LX.ALE0C.045). Is there anyway to get proper BIOS with DMI table for my laptop? Please help me - I don't know what to do. My laptop is very unstable now.

    Thanks!
    Best regards
     
  5. Opus

    Opus MDL Member

    Jul 28, 2009
    157
    27
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. osmoTR

    osmoTR MDL Novice

    May 3, 2009
    15
    1
    0
    i fixed my issue
    modded bios must not flash with "/all" option
    default flash procedure works well with "/fe /b" option
    manually must be change one string in the modded bios "NSLI" to "SLIC"
    slic will be apper
    that's way to work and DMI will not changed acadia to emachines
    now my machine's dmi is acadia no more new device appears

    @ silas
    backuped bios saves orginal dmi data and flash it back dmi it will revent to orginal
    but i don't know to reverse dmi data without backup bios
     
  7. Opus

    Opus MDL Member

    Jul 28, 2009
    157
    27
    10
    Cool, have a nice day
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...