AIO with Server 2008 R2?

Discussion in 'Windows 7' started by lunar21, Nov 8, 2009.

  1. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    #1 lunar21, Nov 8, 2009
    Last edited: Nov 8, 2009
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    ***bump***
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,501
    3,609
    120
    No need to bump, why not just try it yourself, it should work
     
  4. adamsmith

    adamsmith MDL Novice

    Aug 14, 2009
    14
    0
    0
    #4 adamsmith, Nov 10, 2009
    Last edited: Nov 10, 2009
    Hi Lunar21,

    I was going to ask the same question as I've been wanting (and attempting) this myself.

    I actually had it with the 2008 R2 Standard version in the list of available OS's but when you select it, it just said 'Windows could not display the images available for installation'.

    Any suggestions would be appreciated.

    Thanks
     
  5. adamsmith

    adamsmith MDL Novice

    Aug 14, 2009
    14
    0
    0
    Thanks iainstott for your reply.

    I'll check it out and if I find anything I'll post an update.

    Thanks again.
    Adam
     
  6. Fetishquest

    Fetishquest MDL Novice

    May 19, 2009
    20
    0
    0
    #7 Fetishquest, Nov 11, 2009
    Last edited: Nov 11, 2009
    Works fine...

    Even fits on a DVD.
     
  7. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    I tried this and the Windows 7 both 32 and 64 bit work but when i try the server I get this message "Windows could not display the images available for installation". What should I do? what is the problem?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. adamsmith

    adamsmith MDL Novice

    Aug 14, 2009
    14
    0
    0
    Hi Fetishquest,

    Would you be able to point us in the right direction? (as I'm still getting the same error as Lunar21)

    Thanks
    Adam
     
  9. Fetishquest

    Fetishquest MDL Novice

    May 19, 2009
    20
    0
    0
    Aio

    Below is my exact commands. Change drive E to match your drive and delete any lines with versions you dont want.:


    Create Win7-Win2K8-AIO.ISO:

    imagex /delete e:\win7x86\sources\install.wim "Windows 7 STARTER"
    imagex /delete e:\win7x86\sources\install.wim "Windows 7 HOMEBASIC"
    imagex /export e:\win7x64\sources\install.wim 2 e:\win7x86\sources\install.wim "Windows 7 Home Premium x64"
    imagex /export e:\win7x64\sources\install.wim 4 e:\win7x86\sources\install.wim "Windows 7 Ultimate x64"
    imagex /export e:\win7nx64\sources\install.wim 4 e:\win7x86\sources\install.wim "Windows 7 Ultimate N x64"
    imagex /export e:\win7enx64\sources\install.wim 1 e:\win7x86\sources\install.wim "Windows 7 Enterprise N x64"
    imagex /export e:\win7ex64\sources\install.wim 1 e:\win7x86\sources\install.wim "Windows 7 Enterprise x64"
    imagex /export e:\win7nx86\sources\install.wim 4 e:\win7x86\sources\install.wim "Windows 7 Ultimate N x86"
    imagex /export e:\win7ex86\sources\install.wim 1 e:\win7x86\sources\install.wim "Windows 7 Enterprise x86"
    imagex /export e:\win7enx86\sources\install.wim 1 e:\win7x86\sources\install.wim "Windows 7 Enterprise N x86"
    imagex /export e:\win2k8\sources\install.wim 1 e:\win7x86\sources\install.wim "Windows Server 2008 R2 Standard"
    imagex /export e:\win2k8\sources\install.wim 3 e:\win7x86\sources\install.wim "Windows Server 2008 R2 Enterprise"
    oscdimg -u2 -bE:\win7x86\boot\etfsboot.com -lWin7-Win2K8-AIO.ISO -g -h E:\win7x86 E:\Win7-Win2K8-AIO.ISO
     

    Attached Files:

  10. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    Still did not work for me, yes it got it to fit onto 1 DVD, but I still get that error when I select any of the servers to install. Any other ideas? If you got it to work 100%, could you please post how you did it step by step please?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. w_bufffet

    w_bufffet MDL Junior Member

    Oct 22, 2009
    73
    0
    0
    I ran into the same problem. Did you resolve this?
     
  12. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    Well if i did then I would not be asking for his step by step then would i? :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,644
    3,003
    300
    Have you ever thought that the setup.exe maybe different for Windows Server 2008 R2
     
  14. Fetishquest

    Fetishquest MDL Novice

    May 19, 2009
    20
    0
    0
    It's not rocket science...

    Extract each ISO to it's own folder. Use the folder names I posted to make it simple.

    Go to the sources folder in each, delete the ei.cfg file.

    Copy and paste exactly what I posted. I did the entire C & P and just pasted it and one command ran right after the other.

    Profit!
     
  15. iainstott

    iainstott MDL Novice

    Aug 3, 2009
    21
    0
    0
  16. iainstott

    iainstott MDL Novice

    Aug 3, 2009
    21
    0
    0
    @ FetishQueen

    I am going to be trying your method over the next couple of days (when i find the spare time) but just a couple of questions first.

    1. What version of server did you use, as 2008 R2 only comes in the x64 flavour, and on your commands is says x86??
    2. Have you test installed all versions of windows on your disc???

    The reason i am asking is after researching people have had trouble gettin 7 and 2008 R2 to play nice on the same disc. The setup launcher works, but when coming to install, it has corrupted install.wim
     
  17. adamsmith

    adamsmith MDL Novice

    Aug 14, 2009
    14
    0
    0
    Hi All,

    Thanks for all the suggestions, but at this point I don't think it will work.

    Last night, I tried from scratch using a guide I found for Vista/08 and although everything appears to merge ok (including EULA's etc as per Vista/08), but I'm still getting that same error.

    I'm thinking I might just setup WDS, but having everything on an 8GB USB and portable would be great.

    Thanks again to everyone. I'm sure a solution will come at some point, so just continue to hack away at it and hopefully at some point one of us will find a way!

    Adam
     
  18. W0lfdale

    W0lfdale MDL Junior Member

    Aug 28, 2009
    80
    0
    0
    #20 W0lfdale, Nov 12, 2009
    Last edited: Nov 12, 2009
    The solution for AIO Win7 & Server2K8R2 is to merge license folder form Server2K8R2\sources\License with the same folder of Win7

    Edit: This worked only when launching setup from Windows but not when booting from DVD. I'll work on that.