Ami BIOS seems write-protected.. How to disable or circumvent this?

Discussion in 'BIOS Mods' started by allegro16, Dec 30, 2010.

  1. allegro16

    allegro16 MDL Novice

    Aug 3, 2009
    21
    0
    0
    Hi,

    I just got a Slate pc as a present, but unfortunately it has only some form of Linux installed. I wanted to open it up for Windows at least.

    Since there was no new BIOS available to patch for W7, i decided to backup my current..

    AFUDOS tells me "Error: BIOS is write-protected"
    Uniflash 1.40, 1.47, 2.00 tell me there is some form of write protection, and get stuck.
    I can't even create a BIOS backup! -I could at least CHECK if something could be patched..-

    Is there ANY way i could disable or circumvent this protection?
    Using other software or options?

    I could not find a setting in the BIOS setup itself regarding BIOS security/protection. I haven't opened up the tablet yet, since i'm betting it's no jumper but a software thing - Since the manufacturer would have to force users to open it up for a BIOS upgrade, voiding warranty..-

    Bios Information:

    BIOS Vendor: American Megatrends
    Core Version: 4.6.4.0
    Compliency: UEFI 2.0
    BIOS Version: Lucid-MWE-0125
    Build Date and Time: 09/03/2010 18:48:17
    EC Version: 000915

    What i would like, is to creating a backup copy of my current BIOS, check if i could change anything with the amitools available. Getting the BIOS flashed back is another story.

    Thanks,

    Allegro
     
  2. alextheg

    alextheg Super Moderator
    Staff Member

    Jan 7, 2009
    1,773
    800
    60
    UEFI , thats not going to be easy. This thread aboutUEFI , may be of interest to you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. allegro16

    allegro16 MDL Novice

    Aug 3, 2009
    21
    0
    0
    #3 allegro16, Dec 30, 2010
    Last edited: Dec 30, 2010
    (OP)
    Got it backupped!

    Well, i just managed to backup the BIOS! Searched on the AMI site and found an updated download of both the regular and the Aptio bios tools!

    But, now i have a 2MB ROM file that isn't recognised by the mod tools..

    Anyway, the download ami .c o m/support/downloadagreement.cfm?DLFile=support/downloads/amiflash.zip&InpDrvID=288

    I attached the backup of my BIOS.

    One of the AFUDOS options is /A - Oem Activation file, is this of some use?

    BIOS backup: mediafire . c o m/file/4sm7pgqp533pu3s/WETAB.zip
    AMIFLASH: mediafire .c o m/file/5dnib098r8v54v8/amiflash.zip

    Hopefully there is some way to edit this, or another way to get SLIC activation working.. (Like the oa2intelwin tool, etc)

    Allegro

    EDIT:

    Read some stuff here, tried to open with Phoenix tool, and it worked!
    It seems it doesn't need a SLIC mod though:
    'SLIC' string found in ....
    OEM/Table ID's identified are:
    1. MEDIONMEDIONAG
    Pubkey (x1)
    Marker (2.1) (MEDIONMEDIONAG) (x1)

    Didn't expect it, because the WeTab ONLY ships with Meego.

    Still it would be great if there are other tools to change bios settings and options..
    The WeTab has keyboard input disabled at boot UNLESS you insert a Recovery stick and block the lightsensor at boot, while pressing DEL.
    Not very practical, and would be great it that could be changed to just press DEL (or F1,F2, etc)

    Are there any tools to change this?