Application-specific permission settings do not grant Local Activation permission for the COM Server

Discussion in 'Windows 10' started by riajulzanna, Dec 23, 2017.

  1. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    56
    5
    0
  2. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    8,372
    28,723
    270
    All roads lead to Rome :)

    i actually prefer to use NSudo to launch comexp.msc with TrustedInstaller privileges
    this spare you from taking ownership part
     
  3. kgtuning

    kgtuning MDL Junior Member

    Aug 26, 2015
    76
    53
    0
    Most definitely good sir, I was just showing a different way but I'm still learning this windows stuff...
     
  4. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    56
    5
    0
    Hmm thanks for your responses, but see my second uploaded image.
    The Runtime Broker which CSLID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}) already has the local activation permission enabled for that specific user (RAZ\Raz) though I'm getting the 10016 error !!
     
  5. kgtuning

    kgtuning MDL Junior Member

    Aug 26, 2015
    76
    53
    0
    My apologizes, I hadn't noticed that. What is the permissions for Administrators?
     
  6. bear263

    bear263 MDL Novice

    Mar 20, 2011
    12
    4
    0
    Had the exact same error. Same clsid. Mine was caused by the user Network Services. Maybe the user in your error is generic. Try adding Network Services with local activation to see if that removes the error. You can awlays remove Network Services from runtimebroker if that doesn't fix it.