Asrock Fatal1ty z68 gen3 with no name in win 7

Discussion in 'Windows 7' started by mitsub, Jul 21, 2012.

  1. mitsub

    mitsub MDL Novice

    Jul 30, 2009
    7
    0
    0
    I have an Asrock Fatal1ty Z68 GEN3 motherboard which in Win 7 shows under Manufacturer/Model as "To be filled by OEM".
    I bought it second hand and fired it up to test it, and it did, without any problems. The bios wasn't the latest 2.2 so I flashed it with a USB stick. When it completed it said 'press any key to reboot' but it had froze.
    I had to reset it but had no luck in it starting up, just short 5sec.loops and no video.
    Luckily the bios chip is in a socket so I flashed the bios in my programer, not the same bios as in the USB stick but a new download, and it worked ok.
    I loaded Win 7 Ultimate x64 followed by Win Loader 2.1.1 which went ok. Rebooted and then on to site to validate, I think it failed to install the active X part but passed the validation still.
    After loading all updates I tried the performance test and went to print it out, it showed no manufacturer or model id. Checking under 'System' it says '30 days to activate'.
    It passes validation no problem. Loader 2.1.1 puts it as ACER and AIDA64 reports the same as Windows as no motherboard manufactuer or model id.
    I have flashed the Asrock bios again with the USB stick and this time it went ok but still no id for the motherboard.
    Can this be rectified? I'm not sure if the 30 days will cause problems later even though it is validated.
     
  2. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,709
    3,066
    300
    this is common on non branded motherboards, Also ASRock was originally spun off from Asus in 2002 in order to compete with companies like Foxconn for the commodity OEM market.

    As reguards to loader post you questions in Windows-Loader-Support-and-chat latest version of loader is v2.1.7