asrock modded uefi - how to flash

Discussion in 'BIOS Mods' started by mmesh, Sep 7, 2013.

  1. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    Hi,

    I have a problem trying to flash modded BIOS (UEFI) for asrock Z87M Pro4 board.
    I get some kind of "secure" error when trying to use instant flash utility from within UEFI.

    Do I need some other tool to do that? I googled but I can not find any relevant info on this :(
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    Thumb rule for modding/flashing ASRock secure UEFIs:

     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Humphrey

    Humphrey MDL Expert

    Dec 13, 2011
    1,458
    981
    60
    Weird, must not be in my AsRock Extreme4 Z77. I have modded it myself and used a mod by a user here on the forms that updates certain elements (roms) in my bios and no issues yet.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    Only newer ASRock mobos i.e socket FM2 (AMD) and socket 1150 (Intel) are affected.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Humphrey

    Humphrey MDL Expert

    Dec 13, 2011
    1,458
    981
    60
    The board I have is using socket 1155. (i5 3570k)

    Oh I see. This is 4th gen intel?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    I know :D

    1155 = 2nd & 3rd gen processors.
    1150 = 4th (& may be onwards) gen processors.

    ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    Hi, Thanks. I'll try the procedure explained...
     
  8. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    So, I can delete first 4kb from modded BIOS posted here and all should be fine?
     
  9. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    #10 Tito, Sep 8, 2013
    Last edited: Sep 8, 2013
    Delete from original bios, mod it using Module method, then flash it.

    Btw, isn't Loxxx's mod working??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    I was hoping to avoid that because I'm out of the loop. Last BIOS I modded was for the GB X59A MBO some time ago :eek:

    No, it isn't working and that is why I'm asking :(
    It gives me "Secure Flash Check Fail" Error when I try to flash it using Asrock Instant flash.
     
  11. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    #12 mmesh, Sep 8, 2013
    Last edited: Sep 8, 2013
    (OP)
    I'm trying to mod the BIOS(UEFI) myself...

    So, once more, to make a checklist what is needed to be done:

    1. download original 1.60 ROM - check
    2. download phoenix mod tool from this post #1 in thread "Tool to Insert/Replace SLIC in Phoenix / Insyde / Dell / EFI BIOSes" - check
    3. RW everything from rweverything page - check
    4. download SLIC from post #1045 in Thread "OA 2.x SLIC & OEMCERT Collection" - check
    5. delete first 4kb (0x00000000 - 0x00001000 address) from unmodified ROM - check
    6. open Phoenix Tool and supply it with the ROM above - check

    7. open RW Everything and save ACPI table - for this I need to run it on target PC, don't I?
    8. choose ASRock as manufacturer in Phoenix Mod Tool
    9. choose SLIC 2.2 - Dell for example
    10. choose SLP - Dell one that comes with Phoenix Tool for example
    11. choose "Module" under Method
    12. click "Go" Button

    I'm now at my other PC so I need to move to ASRock based one if I'm to continue from number 7., don't I?


    Thank You for all the help!

    P.S. I'm not allowed to post URL links at this moment because I still have less than 20 posts in this forum :(
     
  12. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    RW report is optional for UEFI modding, so you don't need it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    #14 mmesh, Sep 8, 2013
    Last edited: Sep 8, 2013
    (OP)
    OK. Thanks. I'll give it a go.
    Hope that I don't smoke my new PC :)

    P.S. One more question... Can You point me to the best tool for Win8 activation in regard to SLIC2.2 BIOS mod?
     
  14. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    Read this; there is nothing like OEM:SLP activation for Windows 8. However Server 2012 can be activated with SLIC 2.2.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,707
    3,064
    300
    Windows 8 does not use SLIC activation but you can activate with KMS method using Microsoft-Toolkit windows 8 only not 8.1.
     
  16. mmesh

    mmesh MDL Novice

    Sep 19, 2008
    14
    0
    0
    To bad to hear that :(
    I'll read the link You provided...

    So, if the only reason for mod was SLIC activation - I'm out of luck? :confused:

    Oh, nevermind... :rolleyes:

    I'll use a Toolkit urie mentions - Thanks! :worthy:
     
  17. irondick

    irondick MDL Novice

    May 24, 2010
    11
    0
    0
    BIOS ASROCK EXTREME4 v2.70

    Hi all. BIOS ASROCK EXTREME4 v2.70 add to http : // chomikuj . pl / irondick / SYSTEMY + OPERACYJNE / WIN7 / BIOS+ SLIC2.1 + DO + WIN7 / ASROCK + Z87EXT4_2.70,3606774656.7z .