ASUS K52JB: LAN useless after BIOS upgrade

Discussion in 'BIOS Mods' started by SteFir, Dec 14, 2012.

  1. SteFir

    SteFir MDL Novice

    Dec 11, 2012
    1
    0
    0
    Hi there,

    I have a serious problem with my laptop ASUS A52JB after the last BIOS upgrade. The LAN does not work at all, even after having reloaded Default profile with F10. It does not work with Linux, with Windows, with nothing :wallbash:
    The mainboard is a well know K52JB, with a dedicated chip JMicron jmc251 which controls both LAN and Card Reader.
    Interesting, the card reader works fine :confused:

    No success by downgrading the bios to any previous version: the LAN still not working

    Any idea here?
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,268
    1,422
    180
    #2 LatinMcG, Dec 14, 2012
    Last edited: Dec 14, 2012
    if its not driver version ftp://driver.jmicron.com.tw/Ethernet/Windows/JMC2xx_WinDrv_R0.0.33.3_WHQL.zip
    then likely it the mac address was ok with numbers ##:##:##:##:##
    now its missing = FF:FF:FF:FF:FF:FF (get your mac address from router logs hopefully or make one up close to someones same model)

    needs to be reprogrammed to nic chip likely.. ask asus if theres a exe to reprogram it with.

    i see u not the only one, in russia forums
    http://translate.google.com/transla...a=X&ei=Gy7LUOqxFYKy8AS65oHQBw&ved=0CEYQ7gEwAg

    "Tried to boot up and run a DOS utility eemac.exe, here is the result of its work:

    Device: BUS 07 DEV 00 FUN 05
    SMBROM is invalid!! "


    looks like they had to reflash a full dump with SPI programmer.. hope u dont = try the dvd that came with laptop. usualy bios recovery there. Tito knows.

    http://translate.googleusercontent....=38997&usg=ALkJrhgxATO5EnzsaV3infdXNKwvPRk8Gg


    ask asus if any eeprom.exe for jmc251