ASUS P8P67 Deluxe With EFI BIOS successful SLIC 2.1 Mod

Discussion in 'BIOS Mods' started by redturttle, Apr 23, 2011.

  1. redturttle

    redturttle MDL Novice

    Jul 30, 2009
    5
    6
    0
    All:

    As EFI BIOS motherboards are here and the future, I definitely had some confusion and uncertainty in whether or not they could be safely modded, and wanted to share my experience and success. After just purchasing an ASUS P8P67 Deluxe rev 3.0 board and doing a ton of reading, I was able to successfully modify and insert a SLIC 2.1 table and activate Windows 7 with no problem. Procedure:

    Download latest BIOS.
    FLASH the motherboard BIOS to the latest just downloaded.
    Open RW-Everything.
    After RW-Everything Opens, click ACCESS - ACPI Tables.
    When ACPI Tables opens, click anywhere within the ACPI Window.
    Click CONTROL + F2 to save the entire table.
    Open the Phoenix SLIC Tool.
    Open the unmodified BIOS.
    Set manufacturer to ASUS, choose SLIC as ASUS.bin, SLP as ASUS.txt, RW as the table we just saved.
    Method is DYNAMIC.
    Go.
    Save the new _SLIC BIOS. Reboot and flash.
    Shut down machine and reset BIOS with the clear CMOS switch on the back.
    Boot machine and reconfigure the BIOS.
    Load Windows and use slmgr.vbs to load certificate and key as usual.

    Hope this helps and good luck

    Twillux
     
  2. mingo1976

    mingo1976 MDL Novice

    Oct 20, 2010
    35
    7
    0
    hi, i have a p8h61-m and bios is efi too. i did 1 week ago the mod to last bios rev with dynamic method, all went fine. but when i try to flash in ezflash had error: not bios efi file. How did u flash your mobo after mod?
    Tkz for ur attention
     
  3. redturttle

    redturttle MDL Novice

    Jul 30, 2009
    5
    6
    0
    So you're saying that after the bios had a modified installation, you tried to flash it and it wouldn't let you? I just got the board a few days ago and haven't tried to flash it again after the initial modified bios flash... hopefully that's not the case? If so, try flashing in the bios, try using the DOS tool, and worst case, try the crash-free recovery flashing procedure... wonder if any of those three will work? Guess I will find out when ASUS releases a new update.
     
  4. mingo1976

    mingo1976 MDL Novice

    Oct 20, 2010
    35
    7
    0
    problem solved.... i used an old rev of phoenix and bios slic was corrupted... used 1.84 and flashed from ezflash all OK.......tkz for your attention
     
  5. redturttle

    redturttle MDL Novice

    Jul 30, 2009
    5
    6
    0
    That's great news... I used Phoenix v1.84 as well and was a little worried!

    Cheers
     
  6. tuyen

    tuyen MDL Novice

    Dec 13, 2009
    6
    0
    0
    That last step where you clear the CMOS physically with a switch is completely overkill and unnecessary.

    After you flash the BIOS, the only thing you have to do is load the default values by pressing F5.
     
  7. redturttle

    redturttle MDL Novice

    Jul 30, 2009
    5
    6
    0
    Normally I would agree; however, my entire machine would not POST after enumerating the storage controllers. I had to perform a full BIOS reset in order for it to go through; some may have better luck.
     
  8. bmorgan98

    bmorgan98 MDL Novice

    Oct 6, 2010
    10
    3
    0
    Thank you guys for your step by step instructions i successfully imported slic2.1 into a p8h61-m.
     
  9. bios39

    bios39 MDL Novice

    Jun 16, 2009
    1
    0
    0
    I did evertything you posted.

    1- downloaded latest bios 0805.
    2- Flashed latest bios 0805.
    3- use RW-everything to save the acpi table file.
    4- open Pheonix utility version 1.84.
    5- inserted the originale bios i just flashed.
    6- Manufacturer = asus slic file = asus.bin slp=asus.txt RW=file i just created with RW-Everything.
    7- is where i have a problem. I insert the asus-new.xrm.ms certificate and i get an error as follow:

    Complete SLIC2.0 (A M I OEMSLI ) does NOT match certificate (X1) ASUS.BIN matches certificate.

    is this a normal error?
     
  10. schooluser

    schooluser MDL Novice

    Jul 12, 2009
    23
    1
    0
    Thinking of buying this board, can you post the modded bios, possibly with the ASUS executable packaging? People could download and review it, and I could be one of them.

    I would like to give this a shot but I would need more than a step by step since i've never modded, only downloaded.

    You did this within a win7 environment?

    Any bootable iso like the HP slp tool to do this without needing an OS? A PE disk would be awesome.

    Maybe just a zip file with everything needed inside it, I install win7 with the slic key but isn't oem activated yet, mod the bios, restart, install the cert, good to go?
     
  11. slashragnarok

    slashragnarok MDL Novice

    Jun 18, 2011
    4
    0
    0
    Guys I don't understand one thing. If I just flash the BIOS with the new SLIC 2.1 inserted one, wouldn't clearing the CMOS jumper just cancel what I just did?
     
  12. yngdiego

    yngdiego MDL Member

    Feb 14, 2008
    117
    3
    10
    No! Clearing the CMOS does not wipe out the BIOS, just resets the settings back to their default.
     
  13. valskha

    valskha MDL Novice

    Feb 2, 2010
    1
    0
    0
    Thank you so much, i've managed to flash my P8P67-M bios with your method :)

    If anyone wants the moded bios file for this specific board just PM me. (i can't put the link here because apparently my post count is not greater than 20...)
     
  14. colinzim

    colinzim MDL Senior Member

    May 14, 2007
    438
    90
    10
  15. colinzim

    colinzim MDL Senior Member

    May 14, 2007
    438
    90
    10
    #16 colinzim, Oct 11, 2011
    Last edited: Oct 11, 2011
  16. a1pyroman

    a1pyroman MDL Novice

    Jul 30, 2009
    9
    1
    0
    Trying to mod a P8Z68 DELUXE/GEN3...

    Followed all directions but when i select the modded bios in ASUS EZ Flash 2 v01.04 it says read failed (original bios worked fine)

    I used RW1.5.1 and Phoenix 1.93

    datafilehost.com/download-da9389e6.html for rwfile

    Not sure if i did something wrong so I am holding off on flashing in dos

    Any ideas?

    Thank you!
     
  17. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    18,577
    8,265
    340
    Look here http://forums.mydigitallife.net/threads/8909-Make-A-bootable-USb-drive-For-Flashing-From-DOS and here http://forums.mydigitallife.net/thr...quests-section?p=517508&viewfull=1#post517508
     
  18. a1pyroman

    a1pyroman MDL Novice

    Jul 30, 2009
    9
    1
    0
    This one worked with asus ez flash, not sure why the one i made did not work...part of the reason why i didnt try dos originally

    Are you using the slics included with 1.93 or different ones?

    Settings in phoenixDell/EFI SLIC Mod v1.93:
    original bios
    Asus manufacturer
    Slic Asus 2.1 (the one included)
    SLP asus
    RW File (tried blank rw and one from link above)
    Dynamic Method

    Thank you for the help!
     
  19. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    18,577
    8,265
    340
    Same as you, except:
    SLP : --- asus
    RW File: (RWE report from your link above)