Asus X550C Aptio Problem. Any Other Option?

Discussion in 'BIOS Mods' started by namboo, Jul 17, 2014.

  1. namboo

    namboo MDL Novice

    Feb 20, 2008
    30
    0
    0
    #1 namboo, Jul 17, 2014
    Last edited: Jul 17, 2014
    I have an Asus X550C laptop (with original bios ver 212)
    and disabled uefi boot from the "Secure Boot Control" option on the aptio utility
    then formatted its harddrive, installed Windows 7 and applied "X550CA_mod_All".
    Yes, it worked fine with Windows 7 exept there's no "Secure Boot Control" option shown longer.
    That did not matter however because I would not switch it back to secure uefi, before ...

    The problem is:
    Just recently I flashed over the modded ver 212 with original ver 300.
    Looks updating made the secure boot back and locked.
    Now I cannot make it access to any "non-secure" drive including a bootable cd, the harddrive, a usb stick...
    The builtin Easy Flash won't flash back to an older bios.
    This laptop model does not have ez flash back run by Home + Ctrl.

    Anything I shoud do before disassembling my laptop and looking for the spi to unsolder it?

    Thx in advance.
     
  2. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    788
    296
    30
    yeah, you can try to dump the nvdata bios settings using scedos
    paste the result of the dump on pastebin for a review.
    In the worst case you'll get an empty file only or a warning regarding Hii.db access.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. namboo

    namboo MDL Novice

    Feb 20, 2008
    30
    0
    0
    Thanks for your reply.
    My critical problem is that my laptop won't boot up dos because bios cannot access to any non-secure drive due to the locked Secure Boot Control which is now a missing entry...
    USB sticks can be recognized if plugged, but won't show as a bootable drive. Neither will any bootable cd...
     
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,286
    340
    Try the Windows version.

    http://forums.mydigitallife.net/threads/529-Bios-Tools?p=598339&viewfull=1#post598339
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. namboo

    namboo MDL Novice

    Feb 20, 2008
    30
    0
    0
    #5 namboo, Jul 19, 2014
    Last edited: Jul 19, 2014
    (OP)
    Thank you, but that cannot be installed.
    I have no idea if this is because that program does not support Windows 8 or the os runs on a secure disc...
    My laptop wont accept my Windows 7 setup disc either...

    Deos anyone have a Win8 supprted one?
    Or any idea of running dos?
     
  6. MrLacriz

    MrLacriz MDL Novice

    Nov 2, 2009
    4
    2
    0
    Maybe you can unlock your bios to show again these options :

    Open a administrator command line

    Dump your current bios with fpt or fpt64 :
    fpt64.exe -d back64bios.bin -bios

    Take this bios and edit it with AMIBCP :
    In "Security", set "System Mode state" + "Secure Boot Control" + "Secure Boot Mode" from "Default" to "User"
    In "Boot", same for "UEFI Boot" + "Fast Boot" + "Lauch CSM"
    Save with other name

    Flash back your bios : fpt64.exe -f new64bios.bin -bios

    Note1 : Done on an Asus X552CL in the same situation
    Note2 : Every time you flash a new bios, these changes will disapear and you will have to do it again. Take care also of the "Restore to Default" option which sets again Secure boot on
    Note3 : To flash back to an older bios, use winflash with option /nodate. You may try it, but in my experience it does not help to recover these vanished menus.
     
  7. namboo

    namboo MDL Novice

    Feb 20, 2008
    30
    0
    0
    #7 namboo, Jul 21, 2014
    Last edited: Jul 22, 2014
    (OP)
    Thank you for giving me a hope.
    But FPT wont run:

    Error 201: [FPTw.exe] (or FPT.exe or FPTw64.exe) cannot be run on the current platform.
    Please contact your vendor.


    this is of course on the command line as Administrator...

    Deos anyone have a Win8 supprted one?

    ---

    I found & tried a one for different chipsets to get the same error...
    Universal Backup Kit wouldnt run either...

    How?...

    Is it possible to edit the original downloaded one to wrire back?
    Will it cause another problem? Slic will go away?

    I dont understand there will be another problem or loss of slic by reflashing the original one
    because even this time's flashing didnt do that.
    Why do i need a backup of the exsisting rom?

    ---

    I tried looking into the original downloaded one with AMIBCP
    and found two entries for each "System Mode state", "Secure Boot Mode",...(doubled)
    Should i edit both two for each?

    ---

    The reasons why I want to try with the original download are 1. I have not even got a backup so for
    and 2. once the settings reset upon each flashing of a new bios, there will be disk formatting & reinstallation of Windows 8
    needed as well as so many setting steps.
     
  8. MrLacriz

    MrLacriz MDL Novice

    Nov 2, 2009
    4
    2
    0
    Error 201 : might be that your version of FPT is not able to work with the chipset.
    Done with FPTw64 v8.1.10.1286 under win8x64.
    Also, might be that FPT must be installed in directory immediately below root (eg: c:\back\fpt.exe), created with admin rights.

    It is possible to flash back to official older version from Asus, with "winflash /nodate". Easy flash will not let you flash with older bios. slic should not go. However, as said, menus will not reappear (if they do, you win!)

    You need a backup of the existing rom 'cause :
    - winflash neither easyflash will let you flash a modded bios; there must be an asus signature check
    - original bios from asus includes a capsule: size is 6 293 504 bytes = 6MB+2048 (1MB=1024*1024) ; the 2048 bytes is the capsule, and the signature must be there
    - if you remove the capsule then mod, neither winflash or easyflash will accept
    - so flash with fpt, without capsule, then better backup so at least you check that it's able to read the bios

    Double entries : yes, change both. Don't know exactly reason, might be linked to default menu provided by AMI and edited menu from asus, or supervisor and user status.

    If does not work, cannot help you more...