battery not charging

Discussion in 'PC Hardware' started by jakyan, Oct 6, 2012.

  1. jakyan

    jakyan MDL Novice

    Oct 6, 2012
    1
    0
    0
    I just received my Dell Vostro 1510 yesterday and I thought all was well. HA! I only had 4GB of my 16GB formated but no big deal thanks to your forum I managed to fix that. I used it all last night liking this little machine. Last night I turned it off plugged it in and went to bed only to find this morning that it didn't charge? Whats up with that? Has anyone had this problem? When the Dell is on it shows that it is running off AC power and battery charging (1%). However this number never changes,the battery such as pcbatteria.com/dell-vostro-1510.html . It doesn't charge. I tried simple things like removing the battery and putting it back in but no luck. I think I'm just going to return this one and give up on the Dell because I'm afraid of future issues. I am running on the factory installed Ubuntu. If anyone has any suggestions or fixes before I send this back I appreciate it.
     
  2. gabris[LT]

    gabris[LT] MDL Senior Member

    Nov 6, 2010
    434
    243
    10
    try fully discharge it and then charge while lappy is off.
    if that doesn't help just send it to warranty.. :D
     
  3. d.karakasa

    d.karakasa MDL Novice

    Sep 20, 2012
    28
    1
    0
    or

    try another battery
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,352
    1,444
    180
    dell powercords tend to break inside a small white wire of 3 wires, that one charges battery.. center pin.
    (due to wrapping it around charger.. try shoelace style with no pressure on cable).


    if another dell charger dont charge it.. the DC jack is likely damaged on motherboard.
     
  5. lnstevens1976

    lnstevens1976 MDL Junior Member

    Oct 16, 2012
    72
    6
    0
    I've never had good luck with Dell. If I understand correctly this is a new laptop? If so I would warranty out the battery and call Dell. Let them deal with it and figure it out.

    It does sound like a battery issue though. If it was the problem with the charger said above the Bios will "NORMALLY" tell you about. As with my aunts, it goes off if something is off in the charger.