Bios: Acer Aspire l5100

Discussion in 'Virtualization' started by com, Jun 26, 2009.

  1. com

    com MDL Novice

    Jun 26, 2009
    1
    0
    0
  2. karolbe

    karolbe MDL Novice

    Jul 6, 2009
    2
    0
    0
    Yes, this sucks...I also have ACER with disabled VT-x and seems like there will be no VT-x support at least now (this is what ACER support told me).

    I have tried to "hack" the BIOS but I don't have enough knowledge. What I have learned so far is that the BIOS was not written directly in assembler and therefore is quite difficult to read after disassembling. What's more, I have looked into it and unfortunately there is no such obvious code fragment like this one there:

    mov ecx, 0x3a
    rdmsr
    or eax, 0x1
    wrmsr

    There are similar code fragments but they set something in other MSRs (not related to Virtualization). Looks like the BIOS is quite generic because it contains strings about VT-x ("Enable/Disable Vanderpool Virtualization" etc.) in 3 or 4 different languages, so perhaps there is a flag somewhere in the code which would enable more advanced options but since the code was produced by compiler it is difficult to reverse engineer, at least for me.

    The BIOS is composed of number modules which are similar to Windows EXE files (MZ...PE files), good thing is that each module contains a name, so it is easy to distinguish a module which initializes for example HDD from another one. I can write a script to extract those modules. I have tried PE Explorer on those modules but it refused to dissasemble them and none of X86 disassemblers I have was able to dissasemble them in an intelligent way (for example separate code from strings, make labels for strings instead of using hex addresses, it's a pity that there is no such disassembler like Resource I remember from Amiga days).

    There are reports of successful flashes of updated Insyde BIOS so enabling VT-x is a matter of creating a patch :)

    Anyone want to help?
     
  3. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    490
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Alfonso.Esquivel

    Alfonso.Esquivel MDL Novice

    Mar 19, 2012
    1
    0
    0
    BIOS: Acer Aspire 5100

    Hi, I'm new in this forum:

    I got here because I'm looking how to enable virtualization on my Acer 5100. My question is: the modded bios that you provided for the Acer Aspire l5100 also works for the Acer 5100? If not, could you plese help to get one modded BIOS for the Acer 5100 that has the Virtualization features enabled. Thanks for your time.

     
  5. The_Don_Pachuco

    The_Don_Pachuco MDL Novice

    Sep 4, 2013
    1
    0
    0
    Does anyone have a way of modding the 3.13 bios to get rid of the PXE-E01 error that I have that will also unlock other features?