BIOS mod failure (MSI KA790GX, AMI)

Discussion in 'BIOS Mods' started by marhaporkolt, Dec 14, 2010.

  1. marhaporkolt

    marhaporkolt MDL Novice

    Feb 9, 2009
    20
    21
    0
    Hello guys,

    I'm having problem modding a BIOS for my motherboard. It's an MSI KA790GX.
    I tried to mod the latest (1.8) BIOS using the latest AMITool (1.61).
    I downloaded the BIOS from the official MSI site.

    When I open the original BIOS with AMITool, it shows a warning telling me the BIOS already has a SLIC 2.0 table (NEC ) inserted in the F0 module. I click Allow modification.
    I import the Alienware SLIC 2.1 table (it doesn't matter what I choose, it always fails), Method is locked on Dynamic (I can't change to any other method), and click Go.
    AMITool generates the modded BIOS successfully, without any error.
    When I flash the BIOS, reboot and try to activate Windows with the matching certificate and key, it fails. Windows stays in trial mode.

    If I check the SLIC table with SLIC ToolKit V3.2 it says:
    "Dump Error ! (SLIC Table Not found ! )"

    So I'm guessing BIOS mod is failed somehow.
    Am I doing something wrong?

    (My old mobo was a gigabyte with award BIOS, I modded it's BIOS and activated Win7 successfully. I only have problem with this MSI board with AMI BIOS.)
     
  2. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    18,908
    8,372
    340
    Click "Cancel" on popup menu, then
    Vendor - MSI
    Slic - your Slic
    SLP -
    Method - SSv2
     
  3. marhaporkolt

    marhaporkolt MDL Novice

    Feb 9, 2009
    20
    21
    0
    Thank you, it works. :)