BIOS Recovery on Dell Studio 1747 with core i7

Discussion in 'Windows 7' started by s070757, Feb 21, 2010.

  1. s070757

    s070757 MDL Novice

    Feb 21, 2010
    1
    2
    0
    #1 s070757, Feb 21, 2010
    Last edited: Feb 23, 2010
    Forgive me if this is not the right place to post this, but i hope i can help someone with a similar problem. Maybe some1 will find this thread via Google or something.

    Failed a BIOS update on my DELL STUDIO 1747. I didnt have the 7 beeps of death but i was adamant it would happen to me sooner or later since my dell shipped with bios version A02. Besides, i was getting unreasonable hang-ups on Win 7 x86 which are unexplainable.

    Looked around for a solution till i chanced upon the 2 threads below.

    http://forums.mydigitallife.net/thr...enix-Recovery?highlight=dell+studio+1747+bios
    Link for the newest phlash16.exe

    http://forums.mydigitallife.net/threads/14085-Dell-Studio-1737-BIOS-Recovery
    My inspiration

    Steps:

    1. Extract the bios version you desire from official Dell website.
    1a. Have a small USB Drive i.e., one with a filesize allowable by the FAT filesystem. i reserved a 128Mb for this specific purpose. Its only purpose in life is for BIOS flashing and recovery. :biggrin:
    1b. Create a bootable USB-Drive with any of the methods available. You may like to enlist Google's help.
    1c. I installed HP USB Disk Storage Format Tool.exe. IMPT FOR WINDOWS 7 USERS: make sure you run HPUSBFW.EXE as an administrator and Compatibility set to Win XP.
    1d. Copy the XXXX.exe bios file to the USB Drive.

    2. Boot into MS-DOS.
    2a. In MS-DOS prompt, run XXXX.exe -writehdrfile.
    e.g., 1747A07.exe -writehdrfile.
    2b. Contrary to dell's instructions, this command does not give u any workable .hdr file.
    2c. You would obtain PHLASH.exe, BIOS1.wph and CUSTOMER.txt on the drive.
    2d. The PHLASH16.exe obtained should work (UNCONFIRMED. I used step 3's PHLASH16.exe).
    2e. Copy BIOS1.wph to your HDD when you are back in Windows and rename to BIOS.wph.
    2f. CUSTOMER.txt is useless.

    3. Using a pre Win Vista OS (I used Win XP), obtain and run WINCRIS.EXE from the link, "Link for the newest phlash16.exe". Make sure BIOS.wph is in the same directory as WINCRIS.EXE. It will automatically load in the newest phlash16.exe.
    ***WINCRIS.EXE will not run correctly in any compatibility mode on Win 7 x64.***
    3a. You should now have minidos.sys, phlash16.exe and BIOS.WPH on the thumbdrive.


    4. Recover your bios.
    4a. Remove your HDD. It shouldnt matter but do so to eliminate a source for possible troubleshooting.
    Remove battery.
    Insert the USB Drive
    Hold "END" key.
    4b. Plug in AC Power. YOU WILL NOTICE THE WHITE LED INDICATOR FLASHES ONCE INSTEAD OF THE USUAL THREE TIMES.
    No other key combination would work.
    4c. Switch on the Laptop using the power button. The laptop would not automatically power up. Herein lies the difference with Dell Studio 1737.
    4d. Release "END" key.
    4e. When BIOS recovery is complete, the laptop will beep 3 times, silence then repeats the beep-silence cycle indefinitely.

    HELL YEAH. You've got your 1747 back. :D

    Credit: I dun deserve any. Just wanna give something back.
    http://forums.mydigitallife.net/thr...enix-Recovery?highlight=dell+studio+1747+bios
    Link for the newest phlash16.exe

    http://forums.mydigitallife.net/threads/14085-Dell-Studio-1737-BIOS-Recovery
    My inspiration
     
  2. bluebossa

    bluebossa MDL Novice

    Jun 27, 2010
    1
    0
    0
    Update Studio 1747 to Revision A10 with 1747A10_W32-64.exe

    After running in the troubles described above I fortunately found this post. So I first could successfully recover the BIOS rev. A7. (The extraction of the BIOS1.WPH file did not work for me on DOS with the revisions A08 and A10). After having a running system again I opened a command shell and started the 1747A10_W32-64.exe. The installer starts without asking the flash process; please note where the extracted files are placed (C:\Users\Administrator\Local\Temp\WinPhlash64 or something like this). After extraction of the files and before touching the BIOS the installer stops with an error message. I simply took the BIOS1.WPH file and did the work described above with this file. Now I have a running system with the newest BIOS version.
    I hope this helps everybody that will probably fall into the same trap.
     
  3. iceman4357

    iceman4357 MDL Novice

    Aug 28, 2012
    1
    0
    0

    Thread revival....So the 1747 blue screened during a BIOS update and when I start it up its just a blank screen with 3 beeps. I found the latest BIOS A14 from dell, extracted the BIOS1.WPH, renamed it, ran the wincris.exe and created the USB. When I plug in the USB, hold END and turn the computer on the USB drives flashed for a minute, then nothing happens. Is this thing truly bricked?
     
  4. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    Have you contacted Dell at all for technical support? That should always be number one on your troubleshooting list before coming to the forums (even tho this whole website could kick any OEMs but lol)
     
  5. shakeyplace

    shakeyplace MDL Addicted

    May 5, 2007
    861
    75
    30
    From the avtivity you describe I suspect it is not "truly dead".... something is wrong with your procedure. I suggest trying different type things such as releasing the "end" key faster or waiting slightly longer, trying different usb ports, how is your usb drive formatted? The previous post suggests his included some form of mini dos, does yours? (I think wincrisis.exe installs it, doesn't it?) Maybe try a different version of the mini dos, it should be very plain, no extended memory if mine serves me correctly... no himem.sys file (I think that is what it is called), no fancy drivers...

     
  6. Morthian

    Morthian MDL Novice

    Mar 10, 2014
    1
    0
    0
    My 1747 got bricked from a failed BIOS updating. When I try starting it up normally, the screen stays black and I just get a repeating 3-beep error (1 long beep immediately followed by 2 short beeps).

    I've tried flashing the BIOS with a USB drive dozens of times, and I've tried doing EXACTLY what you've said to do here several of those times. It's still not working and I don't know what else to do.

    The only thing I can think of that might possibly be preventing your instructions from working is that there's a Dell Recovery CD in the disc drive. When I try flashing the BIOS, I see the LED on the USB drive blink for a few seconds, as if it's being read, but I can also hear the disc drive spinning. I can't get the disc out, the eject buttons on the keyboard don't respond, and there's no pinhole for manual ejection.

    Could this be preventing the BIOS recovery? Is there something else I can try? Or am I really going to need to physically replace the BIOS chip?