Black screen when launching games

Discussion in 'Windows 7' started by varso, Jan 9, 2010.

  1. varso

    varso MDL Junior Member

    Sep 10, 2009
    54
    0
    0
    #1 varso, Jan 9, 2010
    Last edited: Jan 9, 2010
    Black screen when launching games (SOLVED)

    I have installed W7 X64 Ultimate on my system and it works perfectly except for one serious irritant. I can't play games.

    Every time I launch a game, the screen turns immediately black, the keyboard locks(CAPSLOCK, alt-tab,ctrl-alt-del do not work), the computer does not respond (no task manager) but the hard disk keeps going for a while than blinks. No game sounds. I have to reboot.

    I have a Nvidia Geforce 9800 GT video card with the lates nVidia drivers installed
    directx 11 installed
    no error messages in my event logs.

    I have tried many games but the game I am trying to play is Need for Speed Carbon.

    Due to the lack of error codes, I am lost. I don't even know where to start. Any help is welcome.


    Thanks
     
  2. Dontshoot

    Dontshoot MDL Novice

    Aug 23, 2009
    38
    0
    0
    #2 Dontshoot, Jan 9, 2010
    Last edited: Jan 9, 2010
    Do you have comodo or a similar firewall installed, that asks permission to let the file execute?
    Also why did you install dx11 on a dx10 (not dx10.1 ) card. (But i dont think it maters since it will install the proper dx version)

    9800gt=DX10

    Try going to nvidia.com and downloading the latest geforce 9 series driver.
    It could be over heating. Check the temps. (That's another can of worms)
    Could be a multitude of reasons
     
  3. varso

    varso MDL Junior Member

    Sep 10, 2009
    54
    0
    0
    #3 varso, Jan 9, 2010
    Last edited: Jan 9, 2010
    (OP)
    I will try with DX10. I knew my card was not DX11 ready.

    I do not recall installing dx11 on my system. I thought it came with W7. In addition, normally, software are not supposed to be downward compatible?

    If I install DX10, should DX11 be removed first or both can coexist at the same time?

    Yes I run Comodo but I do not think it is responsible for the computer lock, My keyboard and the Atl-Tab keys would still work but I will keep that possibility in mind anyway. I already have the latest Nvidia geforce 9 series driver installed. I had Microsoft driver before switching to the Nvidia driver. Both drivers crash my computer.
     
  4. Andrew180

    Andrew180 MDL Novice

    Sep 30, 2009
    32
    1
    0
    U guys talkin' about DX10,11,12... :D but this game supports only DX9 :D so try to install it. But it would give you some .dll missing error if that's the problem... try to set compatibility with XP.
     
  5. Glix

    Glix MDL Novice

    Oct 30, 2009
    2
    0
    0
    Wow such bad advice I don't know where to start...

    First off this has nothing to do with Directx 11 that comes with Win 7 and is not even used in NFS: Carbon.

    Go try some beta drivers, and check your sound drivers too.

    Do any of your games work?
    If not, fully uninstall your nvidia drivers using driversweeper and reinstall.
     
  6. Michel

    Michel MDL Expert

    Jul 29, 2009
    1,710
    124
    60
    Try to update the game and use a crack.....maybe it works ;)
     
  7. varso

    varso MDL Junior Member

    Sep 10, 2009
    54
    0
    0
    Solved.

    The lock was caused by Comodo. I disabled it and voila.... :D

    Looks like the directx version is backward compatible. i suspect that if I run a DX11 aware game I will have some problems as my video card is not Directx11 ready.

    Thanks everyones for pitching in. It was much appreciated.

    Now I will try to figure out how to add the word "Solved" on the topic header.
     
  8. whisker27

    whisker27 MDL Novice

    Aug 3, 2009
    5
    0
    0
    This do not happen only to the game you play, most casual games have this bug due to conflict with COMODO Internet Security. You can try my solution whether it will work for you.
    Try not to disable the firewall & antivirus, just turn off defense+. This works perfectly for me.
     
  9. varso

    varso MDL Junior Member

    Sep 10, 2009
    54
    0
    0
    Tried turning off Defense+ as suggested and it works. By turning it off, what is the difference to exiting Comodo?

    Unless there is some advantage to using your method over exiting Comodo, I prefer to exit Comodo. At least that way, not seeing the Comodo icon in the task bar reminds me to reactivate it. With your method, the icon is present and nothing tells you that Defense+ is turned off. There is a chance I will forget to turn it back on after playing a game.
     
  10. ennio

    ennio Guest

    That Comodo is more malware than AV.
    That is funny.
     
  11. whisker27

    whisker27 MDL Novice

    Aug 3, 2009
    5
    0
    0
    I have another solution which I found on the web. I used it with success. Set firewall & defense+ to 'training mode'. Launch the game. If the game open smoothly, quit it after that. Later set firewall & defense+ to your previous settings. The games should run normally after that. Good luck!
     
  12. varso

    varso MDL Junior Member

    Sep 10, 2009
    54
    0
    0
    It worked! Thanks for passing this on. I prefer keeping my firewall running while gaming.