Bootorder cannot be set...

Discussion in 'Application Software' started by ThomasMann, Oct 18, 2018.

  1. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    I use an ASRock B85M and after changing the SSDs I can no longer set the bootorder for these.

    The one I want as default, Win 7, is plugged into Sata 0. The second one, Linux Mint, is plugged into Sata 3. and there is a also CD/DVD player.
    Default right now is the Linux, I can press F11 at start up and choose the Win7.

    When I start up into the B85M and go to "Boot" to change the default, I am offered TWO choices: the Linux and the CD/DVD player, but not the SSD with the windows installation...

    How do I fix that?

    Thank you
     
  2. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    17,268
    21,973
    340
    Check for an extra option to change the HDD Boot order, set the ssd as 1 there, next you will see the ssd in the overall boot order list.
     
  3. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    644
    915
    30
    #3 John Sutherland, Oct 18, 2018
    Last edited: Oct 18, 2018
    Hello @ThomasMann - O.K. I'll run you through what you need to do.

    1.) Go into your BIOS settings and put the device that has Linux Mint installed at the top of the boot order.

    2.) Now boot into Linux Mint.

    3.) Open the Terminal on the taskbar and enter the command "sudo os-prober". You should see Windows 7 appear in the output, telling you that Linux Mint detects Windows 7 on the other disk.

    4.) Now enter the command "sudo update-grub". Close the Terminal, reboot the system, and you should see Windows 7 appear as the last item on the Grub boot menu. Your Grub boot menu should now look like this:

    Linux Mint 19
    Advanced options for Linux Mint 19
    Memory test (memtest86+)
    Memory test (memtest86+, serial console 115200)
    Windows 7

    *Explanation: The first item on the Grub boot menu is assigned 0, not 1, making LM19 item 0 and Windows 7 item 4. Keep this in mind for Step #8.

    5.) By default, if you do not make a selection within 10 seconds, your system will automatically boot into Linux Mint, since it is the first OS listed on the Grub boot menu. In order to make Windows 7 the default OS, you will need to alter one file, /etc/default/grub.

    6.) Open the Terminal and enter "sudo apt-get install leafpad". This installs the text editor leafpad, which is a little easier to use than nano.

    7.) Now enter "sudo leafpad /etc/default/grub". When leafpad opens to display the file, expand the screen to full to make viewing a little easier.

    8.) Examine the file and find the line "GRUB_DEFAULT=0". Now change the 0 to 4. *See above

    9.) After making the change, go up and click "File", then select "Save" on the pop-up menu. Then click "File" a second time, and select "Quit" from the menu. Leafpad will close.

    10.) Now enter "sudo update-grub" to apply the change.

    11.) Close the Terminal and reboot. If you do nothing, after 10 seconds Windows 7 will boot as the default OS.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    Two days ago I have installed Linux once again for the first time... and now this.... I do not even know what grub actually is exactly, let alone work with it, and I really do not want to know it, to say the truth...
    I want to, and I have, installed Linux on a an empty disk, and plugged it into a higher # at sata, so it would not be #1 at boot.
    And now you tell me that Linux does not give a **** what I actually want`? Is that assumption correct?
     
  5. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60


    Thanks, there was no extra option on that Bios page, but there was a possibility to remove the CD/DVD form the list which allows only two boot options and then set Win as #1.
    So far it works fine.
     
  6. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    644
    915
    30
    Hello @ThomasMann - O.K. You have Windows 7 on one disk, Linux Mint on the other. Right now you have to use your BIOS to choose which operating system you wish to boot, which is inconvenient at best, and a pain in the ass if it involves using a sequence of keys, like HP with it's Esc>F9>Up/Down Arrow>Enter.

    Now, the big difference between Windows and Linux. Windows is only aware of other Windows operating systems. It cannot recognize a Linux OS, so you cannot boot Linux from Windows, unless you resort to using third-party software. It's Windows that doesn't give it sh*t what you want. Windows only concerns itself with Windows, and nothing else exists in it's world.

    On the other hand, Linux uses Grub, which is a universal boot loader. It is not only aware of other Linux operating systems, but is also aware of Windows as well. So, if you want to dual-boot without using third-party software, or without using your BIOS boot menu every time, you should boot using Grub, which means your disk with Linux Mint should be the first device in the BIOS boot order.

    Read through what I described above. It's not that difficult.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,562
    2,228
    90
    Some firmware (BIOS/UEFI) will offer only one of each device type in the boot sequence. If you have more than one HDD installed, there is another setting below where it lists all HDDs, you need then to select the one that should appear in the boot sequence.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    Yes... because having no clue about grub at all yet, I see no problem there.
    But I think I saw a different problem there altogether.

    The Win7 SSD was there first, it is plugged into sata0. Yet after installing Mint on another SSD, being plugged into sata3, it was the Win SSD that was kicked out of the boot order in the Motherboard, and not only replaced by the MInt one. But it also replaced my Win7 default selection in the bootorder at start-up, and it replaced it with itself! Without telling me, and of course, without asking me.
    So to me it seems to be the other way around... Linux kicked out Windows!

    I am having a hard time defending Windows, but this behaviour of Linux reminds me of my previous stressful attempts of replacing Win with Linux....

    Now, I have simply unplugged the Mint SSD and Win turned up on the boot page of the motherboard again, and i could change it to became default again.
    After plugging the MInt SSD in, it seems to remain at boot-choice #2
    If I actually would have to do, what John Sutherland described in #3, then I would get rid off Linux once and for all in this life. I know he meant well, and it must have cost him quite some time, but... A computer for me is something like a car or a fridge, I use it to make my life easier. it is NOT the content of my life.
    I have a life in the real world outside already. ;-)
    Why do Linux Users always give me the impression, for them it is the other way around?
     
  9. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,869
    2,032
    210
    In the later AMI BIOS-Setup, to set the Boot-Order properly, you need to open up the Boot Menue and set the Boot-Order for the Hard Drives first under Hard Drive BBS Properties, following by set the correct Hard Drive under Boot Options #1/#2/#3 in the right order.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,869
    2,032
    210
    Forget to mention: next time you ask for specific help, please also state the correct Version of your Hardware, in your case, which of the MB model you use, there at least 7 or 8 different available!

    Therefore I could not give the right and correct advice. Sorry about that!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    If you look. you will find that it is mentioned in the very first sentence.

    I fixed the problem, but the actual question was not answered. Does Linus usurp the right to change settings like this one on my computer, without asking or at least telling me? Because if it does, it is worse than MS, and my reason for switching has just become obsolet.
     
  12. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,869
    2,032
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,869
    2,032
    210
    That's the one I talked about as the 'Older Model' (the first of the B85M Series. That one was built for Windows 8. The problem you were getting is AMI-BIOS related. I had a similar problem with such AMI-BIOS, on a different MB, and was getting an Update for the MB Developer for to solve, on the way I explained in my first post. Later on, I got several different MB's, various developer, and all with the initial standard AMI-Bios (Release Version of the MB's) had the same problem. All needed an Update.

    Regarding Linux, we all should not forget that most of the Linux Distros are 'modified' from Users because most of them are Open-Source. The cleanest Linux OS'es are Suse, Debian, and CentOS, according to Linux experts Most of the so-called Distros are modified from within those Linux OS'es.
    Not my own talking, I just got those from real Linux experts, developers, and programmers, people who really should know what they're talking about!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,562
    2,228
    90
    Linux Mint is a fork from Ubuntu, but it also has an Edition that's forked from Debian (LMDE).

    In the old BIOS firmware, the Boot order was usually set there and not changed anymore. Modern UEFI firmware allows controlling and setting nearly all options from within the OS. For example, UEFI hands over the boot sequence to the Windows Boot Manager if Windows is installed in UEFI mode. GRUB in UEFI mode might do the same and you set your boot order in the GRUB config directly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    I have so far tried Suse, Ubuntu, Debian and now Mint in the last decade. And with all of them problems to get a simple set-up correct where just too much, so I returned to Win7.
    It is what I hate most about ALL software, people trying to do me favors, that NO ONE asked for.
    In the mornings I usually use a VPN through Hongkong... You have no idea how many websites will automatically force open the chinese language version of their website.

    And Mint will be the last one I try in this life.
    I promise:D
     
  16. ThomasMann

    ThomasMann MDL Expert

    Dec 31, 2015
    1,045
    163
    60
    I have tried several different Linux installations. I have yet to see one whose installation does not result in a whole album of totally unnecessary queeries, just to get it working with the most possible simple set up.... You constantly run into such garbage... changing the boot order, even without asking or at least telling...
    Its like Firefox helping "me" improve its use, by adding telemetry... Websites telling me, what language I use, or what "my" time is, and changing that s**t on "my" computer...

    I think my next hobby will be to learn how to build one of these electronic shock wave bombs, that wipes all memories.... :cool: