Bricked Dell Inspiron 14 3421 Bios, will pay to get it working!

Discussion in 'BIOS Mods' started by kinta123, Oct 7, 2013.

  1. kinta123

    kinta123 MDL Novice

    Oct 7, 2013
    9
    0
    0
    Hey guys today i bricked my dell bios after trying to update with modded Bios

    So far this is what i have tried to get it back..

    Downloaded latest bios from dell website A05
    ran cmd 3421A05.exe /writeromfile
    3421A05.exe /writehdrfile
    Unplugged everything on the laptop
    Held END key then plugged in charger, power LED came on but black screen and nothing happens, no recovery mode.
    tried flashing the .hdr file renaming it to OAK14.hdr, OAK1405.hdr (Didn't work)
    tried flashing the .rom file renaming it to OAK14.rom, OAK1405.rom (didn't work)

    I placed both files in the root of the USB 2GB Sandisk Cruzer one at a time. Someone suggested i put amifldrv32.sys and amifldrv64.sys in the root as well. Still no go. I really need your help.. someone.. anyone! is the link to the original bios
     
  2. tqhoang

    tqhoang MDL BIOS Modder

    Apr 29, 2008
    1,412
    280
    60
    When you extract the ROM file from the Dell updater (ex: 3421A05.exe /writeromfile), try copying/renaming the "3421a05.rom" to "AMIBOOT.ROM". Then follow the procedure in the AMI BIOS Recovery Method.

    Let use know how you make out. Good luck!
     
  3. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,486
    1,501
    180
    i think he needs to use original same as he had before bios failure.
    A02 ? A03
     
  4. kinta123

    kinta123 MDL Novice

    Oct 7, 2013
    9
    0
    0
    i tried that method already too, i believe there is a step missing, holding the END key does turn it on and no other key (aside from the power) does that. There must be a specific type of .rom file specific for the newer laptops.. that being said i returned it to the shop and i have to wait bout a month for a replacement