Build 10162 - remote desktop server not working?

Discussion in 'Windows 10' started by JesseKnows, Jul 7, 2015.

Tags:
  1. JesseKnows

    JesseKnows MDL Novice

    May 24, 2009
    13
    0
    0
    I have been using RDP to connect from a Win7 system to another computer for years. Now that computer is on Win10 fast track. The connection worked fine as recently as yesterday.
    This morning I find that computer has rebooted after installing 10162, and RDP can't connect. When I try, I see "Initiating remote connection" for 10 seconds or so, then it shows me "Remote Desktop can't connect..." error.

    I tried to reboot the Win10 machine, no difference. I did not see messages in the event log relating to the RDP, but I am not sure what to look for.
    I see that the Remote Desktop Services are running.
    I confirmed that the Remote Desktop is enabled in Settings, and my user name is listed.

    The Win7 client still connects to another Win7 machine on the network. I had recently installed KB2592687 ("RDP 8.0 update") on the client machine, and following that installation it successfully connected to the Win10 machine with the previous build.
     
  2. TeamOS

    TeamOS MDL Guru

    May 27, 2013
    3,029
    1,701
    120
    works perfect on me :D
     
  3. Don

    Don MDL Expert

    Jul 29, 2009
    1,366
    124
    60
    Try redefining it.
     
  4. chilsaoui

    chilsaoui MDL Member

    Mar 21, 2015
    108
    14
    10
    use the pro or enterprise version
     
  5. Elle233

    Elle233 MDL Member

    Aug 26, 2009
    194
    16
    10
    I'm on Pro version. It works perfectly on mine
     
  6. alien2xx

    alien2xx MDL Senior Member

    Aug 5, 2009
    384
    189
    10
    #6 alien2xx, Jul 7, 2015
    Last edited: Jul 7, 2015
    Control Panel > Security > "Windows Firewall" > "Allow Programs or feature through Windows Firewall" option

    Check Firewall settings for Remote Desktops, enable for all scopes and try again.. upgrading sometimes reset the firewall settings.


    You can also check the RD client applet (from windows 7), Advanced tab and check under Server authentication: "Connect and dont warn me"
     
  7. Zardoc

    Zardoc MDL Senior Member

    Feb 7, 2008
    483
    196
    10
    It should work by default.

    I'm running a secure app with RDC man and have more than 60 connections working. :tasty:
     
  8. JesseKnows

    JesseKnows MDL Novice

    May 24, 2009
    13
    0
    0
    Solved!

    Somehow during the update my network connection type got changed to Public, which disabled RDP. I changed it to Private and now RDP works.

    Following a web suggestion (can't post link with too few postings:mad:), I used the Network Troubleshooter to change the connection type. Is there a more direct way to make this change?
     
  9. Mance

    Mance MDL Novice

    Jun 20, 2014
    10
    9
    0
    Gpedit.msc

    View attachment 36879
     
  10. cengizhan

    cengizhan MDL Senior Member

    Jul 29, 2009
    371
    88
    10
    there should be a microsoft fix it tool for this. this is a common problem which also disables file sharing.