Bypass Windows 7 Extended Security Updates Eligibility

Discussion in 'MDL Projects and Applications' started by abbodi1406, Nov 17, 2019.

  1. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,050
    38,873
    340
    #1 abbodi1406, Nov 17, 2019
    Last edited: Dec 9, 2019
  2. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,050
    38,873
    340
    #2 abbodi1406, Nov 17, 2019
    Last edited: Dec 15, 2019 at 18:00
    (OP)
    How to test:

    - install the SHA2 prerequisites:
    KB4490628 -> KB4474419 -> reboot

    - install the latest servicing stack update
    KB4531786 (previously KB4523206, KB4516655)

    - install BypassESU

    - install the ESU test update KB4528069
     
  3. hamdoullah

    hamdoullah MDL Novice

    Oct 27, 2019
    6
    0
    0
    @abbodi1406

    Thanks for this. i installed successfully KB4528069 after following instructions above.
    so if i understand what you said above, now that this update is installed, that means that i will get updates through WU over 2020 until 2023 on my win7 machine.
    Can you confirm ?
     
  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,816
    12,107
    340
    #4 Yen, Nov 17, 2019
    Last edited: Nov 17, 2019
    I am moving this to MDL Projects and Applications and stick it.

    Please no alternative links to different files. Only OP supports this MDL project here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,050
    38,873
    340
  6. Windows_Addict

    Windows_Addict MDL Senior Member

    Jul 19, 2018
    303
    473
    10
    #6 Windows_Addict, Nov 17, 2019
    Last edited: Nov 17, 2019
    To be clear, this method is originally @abbodi1406 's idea (he is too humble to mention it.), and mspaintmsi and others contributed to it. (mspaintmsi posted this method on nsaneforum.)
     
  7. NST_Adventure

    NST_Adventure MDL Senior Member

    Jun 1, 2019
    307
    38
    10
    Pin It :worthy:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. mspaintmsi

    mspaintmsi MDL Novice

    May 9, 2015
    24
    152
    0
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. mspaintmsi

    mspaintmsi MDL Novice

    May 9, 2015
    24
    152
    0
    @the_soft45
    Apparently, the test update installs on Vista without any problems and does not need any tools to do so.
    Just in case, we have a fix ready for when Microsoft changes this.

    (It'll most likely change in the near future as Microsoft probably just forgot that Vista still exists)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,050
    38,873
    340
    @paintMSI

    The ESU eligibility component (amd64_microsoft-windows-s..edsecurityupdatesai_31bf3856ad364e35_6.0.6003.20777_none_c87c6e70d53a1370.manifest) is only installed on Server editions
    Client editions only install calc.exe

    but i think you can force installing the ESU component on client
    expand.exe the update cab, then install the relevant sub-package
    Code:
    start /w PkgMgr.exe /ip /m:"expanded_folder\package_2_for_kb4528081~31bf3856ad364e35~amd64~~6.0.1.2.mum" /quiet /norestart
    according to the manifest, it should work similar to Windows 7
    but the returned SKU should always be ServerStandard

    does Vista have TrustedInstaller.exe?
     
  11. mspaintmsi

    mspaintmsi MDL Novice

    May 9, 2015
    24
    152
    0
    @abbodi1406
    TrustedInstaller exists in Windows Vista and superUser should work just as good on Vista as on other versions.

    I'll try playing around some more with the things you provided. Thanks .-.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. hamdoullah

    hamdoullah MDL Novice

    Oct 27, 2019
    6
    0
    0
    @abbodi1406

    Also if i understand well, the project will also allow to receive updates on unsupported win7 editions (home premium, basic home and starter).
    Confirm this ?
     
  13. Windows_Addict

    Windows_Addict MDL Senior Member

    Jul 19, 2018
    303
    473
    10
    Yes.

     
  14. hamdoullah

    hamdoullah MDL Novice

    Oct 27, 2019
    6
    0
    0
    #18 hamdoullah, Nov 18, 2019
    Last edited: Nov 18, 2019
    ok thanks for your reply
    one thing i didn't get , the project through the script "install.bat" is already configured by default to allow to receive updates on all win7 editions. Right ?
    So what's the point of editing "install.bat" and set ForceHook to 1 as it is mentionned in first post ?
     
  15. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,050
    38,873
    340
    Right

    options are good :)
    SlcShim loophole is safer, but can be easily patched/closed by Microsoft
     
  16. -=ismail=-

    -=ismail=- MDL Member

    Jul 25, 2013
    108
    443
    10
    #20 -=ismail=-, Nov 18, 2019
    Last edited: Nov 19, 2019
    -deleted-

    It was just for information...

    *Lost in Translation*
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...