Calculator not working with UAC off in windows 8.1u1

Discussion in 'Windows 8' started by taviruni, May 1, 2014.

  1. taviruni

    taviruni MDL Member

    May 8, 2010
    191
    110
    10
    #1 taviruni, May 1, 2014
    Last edited: May 1, 2014
    I googled for this and didn’t find any info, also googled in the forum and same result.

    Just installed Win 8.1 Pro x86 with Update 1 and I disabled UAC, when I try to run calculator there is a message "Calculator do not run if UAC is disabled" and it offers to enable UAC, This do no happen in Win 8.0.
    I do not like to use UAC but obviously I need to use calculator, Is there a work around for this?

    Thanks in advance.
     
  2. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,376
    210
    Tried the winkey+r "calc" version?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. taviruni

    taviruni MDL Member

    May 8, 2010
    191
    110
    10
    Not myself but when googled the only topic I foud was abut Winkey + r do not work when UAC is disabled in Win 8.1U1, there are other people confirming it but no one give a solution, so I didn't try.
     
  4. eydee

    eydee Guest

    Then find calc.exe in c:\windows\system32 manually and use it.
     
  5. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,494
    15,283
    340
    Metro/Modern calculator doesn't open if UAC is off. There is no effect on the desktop app.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,748
    1,959
    210
    There many other Metro-Apps which will not working if the UAC is turned off! I didn't use any of the Metro-Apps!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,494
    15,283
    340
    Small correction, it should be 'all'. This is by design.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. burfadel

    burfadel MDL EXE>MSP/CAB

    Aug 19, 2009
    2,628
    3,839
    90
    No Metro app will work with UAC turned off, it's by design. Of course, a better design would be a mixed UAC (well, actually LUA being disabled) mode, where you run the desktop with LUA disabled but metro apps run with UAC. Of course, Microsoft doesn't want to encourage people to disable LUA, so they haven't done this.

    To completely turn off UAC you need to set the EnableLUA registry key to 0.

    The Winkey + R does work with LUA/UAC disabled, if it's not then there's something screwy going on!
     
  9. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,748
    1,959
    210
    Some Metro-Apps still working, even UAC is turned off! I've UAC turned off and I could still start some Metro-Apps, even the Store!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. SpeedDream

    SpeedDream MDL Addicted

    Feb 20, 2012
    620
    121
    30
    #10 SpeedDream, May 1, 2014
    Last edited by a moderator: Apr 20, 2017
    no UAC no metro,
    this is the trick to disable uac: command prompt (admin) and:
    Code:
     reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /f /v EnableLUA /t REG_DWORD /d 0
    to re-enable:
    Code:
    reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /f /v EnableLUA /t REG_DWORD /d 1
     
  11. taviruni

    taviruni MDL Member

    May 8, 2010
    191
    110
    10
    #11 taviruni, May 2, 2014
    Last edited: May 3, 2014
    (OP)
    I disabled it using:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "EnableLUA"=dword:00000000

    Well I'll have to install some start menu application to run what is blocked (haven't find any other, but just in case)

    Which one do you recommend?
     
  12. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,376
    210
    Why don't you just re-enable it with by changing that registry to 1 and then move the slider down to the off position?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. taviruni

    taviruni MDL Member

    May 8, 2010
    191
    110
    10
    Just installed ClassicShell v4.1.0, and problem solved, even better I don't see that stupid metro any more, that is for tablets no PC's. I'm going to use the PC, Microsoft should not think what is better for me, the farter they should go is give me alternatives and let me take the one I like better.

    Thank to you for your time and advices.