Can not get WinPE4x to boot from local disk...

Discussion in 'Windows 8' started by brianfgonzalez, Sep 13, 2013.

  1. brianfgonzalez

    brianfgonzalez MDL Novice

    Mar 31, 2011
    1
    0
    0
    Any help is MUCH appreciated! I've been stuck here for a bit.

    Here is my bcd, that I'm creating via a script.

    4IfgBE4.jpg

    pHarZEB.jpg
    qD6gNBQ.jpg

    /Brian G
     
  2. MSMG

    MSMG MDL Developer

    Jul 15, 2011
    2,122
    4,808
    90
    #2 MSMG, Sep 13, 2013
    Last edited by a moderator: Apr 20, 2017

    May this will be helpful to you

    Code:
    Add an entry to BCD
    ===================
    
    Usually, the {ramdiskoptions} entry is not created when installing Windows. Just make sure if it is there or not with the following command.
    
    bcdedit /enum {ramdiskoptions}
    
    If it says "There are no matching objects or the store is empty", that indicates {ramdskoptions} entry has not been created. Create it with the following commands.
    
    bcdedit /create {ramdiskoptions}
    bcdedit /set {ramdiskoptions} ramdisksdidevice boot
    bcdedit /set {ramdiskoptions} ramdisksdipath \boot\boot.sdi
    
    Now, create the actual entry with following commands.
    
    bcdedit /create /d "WinPE boot" /application osloader
    
    After successfully creating the entry, this will display the {GUID} of the entry in format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. 
    Use that value in the following commands.
    
    bcdedit /set {GUID} device ramdisk=[C:]\Images\winpe.wim,{ramdiskoptions}
    bcdedit /set {GUID} osdevice ramdisk=[C:]\Images\winpe.wim,{ramdiskoptions}
    bcdedit /set {GUID} systemroot \Windows
    bcdedit /set {GUID} detecthal Yes
    bcdedit /set {GUID} WinPE Yes
    
    Finally, add it to the current boot options list with
    bcdedit /displayorder {GUID} /addlast
    
    Reboot the system and select WInPE boot to boot to WinPE
    
    Notes:
        In boot menu, if "Ramdisk Options" is displayed instead of the description of WinPE, remove the description of the {ramdiskoptions} with the following command.
    
    bcdedit /deletevalue {ramdiskoptions} description
    
        If booting to winpe fails and says "A required device is not accessible", check if you have copied the boot.sdi file to the correct location.
    
    
     
  3. MrChris

    MrChris MDL Senior Member

    Jun 23, 2007
    440
    87
    10
    Have you tried easybcd? I've always Used that to create and edit my BCD menu.