Can't get w10 to detect my secondary display (LG TV)

Discussion in 'Windows 10' started by celahudini, Jul 19, 2016.

  1. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    So guys as the title says I'm having troubles for some time now with windows 10 not being able to detect my secondary display which is a LG lb650v smart TV connected through hdmi.
    Had this problem for a while with earlier builds and thought my cable died. But recently went back to win7 and there the TV works just fine.
    Then yesterday did a clean install of win10 x64 pro build 10586.494 and once again it doesn't detect any secondary display under display settings.
    My gpu is a nvidia gtx 560 ti and my primary display is a 22" monitor connected through DVI, while the secondary display device is the above mentioned LG LB650V tv connected through hdmi.
    I have the latest win10 nvidia display drivers (there's not even a newer beta version available), and windows update doesn't find any driver update. Also there's no driver missing from device manager.
    Any ideas how to fix this?
     
  2. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    did you try any earlier driver, or maybe installing a win7 driver? my pc detects my LG TV on HDMI 2 just fine , nvidia GT 540M win 10 driver.

     
  3. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    I did. Tried the latest 368.81 with the latest beta geforce experience. Went back through a number of older drivers, all the way to 35x.xx from 2015. Still get the same results.
    It wont let me install win7 drivers, says it's not for this version of windows. Have no idea what else I could try
     
  4. hbhb

    hbhb MDL Expert

    Dec 15, 2010
    1,017
    263
    60
    can you install win 7 driver in compatibility mode?
    btw running 359.46 here
     
  5. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    #5 lobo11, Jul 21, 2016
    Last edited: Jul 21, 2016
    You have to run cable DVI or HDMI to TV for it to work, back of your computer, 1 video output to monitor, use what ever else you have to run cable to TV:D

    Why is cable running to HDMI 2, what's wrong with HDMI 1, Sounds like cable from computer is not hooked up to correct input on TV, thus no picture or sound, or you have not changed on TV which input it should connect to, play with input button on remote until you are receiving signal from computer, put back on newest driver.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    Will try it now and let you now how it goes

    The gpu and this entire PC for that matter are pretty old for nowdays standards. The gpu has 2 DVI outputs and only 1 HDMI (mini HDMI). Anyways the monitor doesn't have speakers nor a hdmi port lol so even if the graphic card had more hdmi ports I don't see the point in connecting the monitor through HDMI when I only need the picture on the monitor. But like I said I set it up like it is now years ago and it's been working fine, I tried it on win7 3-4 days ago with the exact same setup and it works. When switching between inputs on the TV itself the TV registers the computer as a connected device that is running but the computer or more specifically win 10 doesn't register the TV so the TV doesn't reproduce any picture or sound from the PC no matter what I do.
     
  7. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    #7 lobo11, Jul 21, 2016
    Last edited: Jul 21, 2016
    Do you have DVI cable running to your Tv?
    If you have TV hooked up with mini-HDMI TO HDMI-2 input (forget computer hookup) now set TV source to HDMI-2
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    Can't install any win7 driver even when in compability mode. Can't post imgs or links here because of my post count but I tried 359.06 and 361.75 in compatibility mode and got the same result:
    hd audio driver not installed
    graphics driver failed


    I do have a dvi-hdmi cable but don't use it anymore cause it doesn't transfer sound unlike hdmi.
    And the mini-hdmi to hdmi is connected to hdmi 1 port in the tv (calibrated image and a bunch of other stuff). The tv does have 2 other hdmi ports that I use but also tried connecting the pc through them and still the problem persists. So I'm pretty sure the tv isn't the issue, but this M$ spying bs called a os
     
  9. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    #9 lobo11, Jul 21, 2016
    Last edited: Jul 21, 2016
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    imgur . com/ZTPdNDU
    imgur . com/mbz25S3
    I did turn off automatic windows update and also I uninstalled every metro app that I can uninstall from the start menu like "get skype, 3d buillder, sports, money, twitter, get office etc, solitaire collection,candy crash" and all the other bloatware that could be uninstalled without using a special program/script for it
     
  11. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    #11 lobo11, Jul 21, 2016
    Last edited: Jul 21, 2016
    I would think that you have turned off/disabled something that is required for it to work on Win 10, Do in place upgrade, save everything, will put everything back on Win 10, then after you get it working, 1 at a time do your tweaks until you find which one is causing it to stop broadcasting to TV.

    It must pass repair test in Admin Cmd Prompt: sfc /scannow
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    I tried sfc /scannow and it didn't help. Then did another clean install with a format ofc. Installed the latest drivers and nothing else and it still doesn't detect the tv.
    At this point I'm thinking about going back to one of the earliest builds, just don't know if I can turn off that annoying message about an upgrade to a newer build
     
  13. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    #13 lobo11, Jul 23, 2016
    Last edited: Jul 23, 2016
    Have you done any tweaks to it and I would wait and fresh install Anniversary Update before I went back to anything.:D

    Can anyone think of anything

    Unplug your HDMI cable, Plug it back in reboot
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Jari

    Jari MDL Member

    Jan 18, 2013
    220
    50
    10
    #14 Jari, Jul 23, 2016
    Last edited: Jul 23, 2016
    Just wondering if it has something to do with new MS driver, 10.0.14393.0 dated 21st June 2016, for generic PnP monitor (HDMI) ?
     

    Attached Files:

  15. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    @celahudini,
    You're using mini HDMI, which means maybe you are using adapter, try plugging your computer monitor into adapter to see if it's any good, if it works, try the other HDMI cable going to TV, plug into adapter, HDMI cable (TV one) to your monitor.:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    No I would not think so, I have DVI driver for my monitor dated 6/2/2006 and HDMI out to TV, works:D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,796
    6,742
    270
    Ive tried with an Asus laptop, a Dell laptop, and 2 desktop systems with no luck getting HDMI working in Win10 out to TV.

    The surfacepro4 works though hahah
     
  18. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,180
    3,357
    210
    Surly yee jest:eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    Nope, didn't tweak anything. Fresh install, downloaded the latest drivers and installed them and that's it.
    Yes I'm using mini HDMI because my graphics card has only 1 mini hdmi port so there's no other way to connect it. I tried other cables, but like I said the cable and the adapter work fine, otherwise it wouldn't work on windows 7.
     
  20. celahudini

    celahudini MDL Novice

    Sep 14, 2012
    11
    3
    0
    Well I went back to the 6851151 build and it works just fine. Disabled auto update and that's that. Thanks to everyone for your replies.