Changing install.wim default time zone from Pacific Standard Time

Discussion in 'Windows 8' started by A-bit_Tinkerer, Nov 17, 2014.

  1. A-bit_Tinkerer

    A-bit_Tinkerer MDL Junior Member

    Mar 24, 2014
    61
    45
    0
    #1 A-bit_Tinkerer, Nov 17, 2014
    Last edited by a moderator: Apr 20, 2017
    In a command script, the following commands are used to change the install.wim default time zone from Pacific Standard Time to Eastern Standard Time.

    Code:
    %dism_exe% /Mount-Wim /WimFile:%WorkingDir%%ImageDir%\%WimFile% /Index:%%i /MountDir:%WorkingDir%%MountDir%
    
    %dism_exe% /Get-MountedWimInfo
    
    %dism_exe% /Image:%WorkingDir%%MountDir% /Get-Intl 1>%WorkingDir%%LogPath%\Get-Intl_!WimArch!_[%%i].log 2>&1
    
    %dism_exe% /Image:%WorkingDir%%MountDir% /Set-TimeZone:%TimeZone%
    
    %dism_exe% /Image:%WorkingDir%%MountDir% /Get-Intl 1>>%WorkingDir%%LogPath%\Get-Intl_!WimArch!_[%%i].log 2>&1
    
    Shown below are the contents of a log file that is used to capture the settings that are reported both before and after setting the time zone.

    Code:
      Deployment Image Servicing and Management tool
      Version: 6.3.9600.17031
    
      Image Version: 6.3.9600.17031
    
      Reporting offline international settings.
    
      Default system UI language : en-US
      System locale : en-US
      Default time zone : Pacific Standard Time
      User locale for default user : en-US
      Location : United States (GEOID = 244)
      Active keyboard(s) : 0409:00000409
      Keyboard layered driver : PC/AT Enhanced Keyboard (101/102-Key)
    
      Installed language(s): en-US
        Type : Fully localized language.
    
      The operation completed successfully.
    
    Code:
      Deployment Image Servicing and Management tool
      Version: 6.3.9600.17031
    
      Image Version: 6.3.9600.17031
    
      Reporting offline international settings.
    
      Default system UI language : en-US
      System locale : en-US
      Default time zone : Eastern Standard Time
      User locale for default user : en-US
      Location : United States (GEOID = 244)
      Active keyboard(s) : 0409:00000409
      Keyboard layered driver : PC/AT Enhanced Keyboard (101/102-Key)
    
      Installed language(s): en-US
        Type : Fully localized language.
    
      The operation completed successfully.
    
    The default time zone appears to have been sucessfully changed from Pacific Standard Time to Eastern Standard Time. However, after install, the time zone is still Pacific Standard Time.

    Why is the time zone not Eastern Standard Time after install?
     
  2. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    8,102
    27,033
    270
    Do you mean when you install (the first install screen)?
    and how do you deploy this modified image?
     
  3. A-bit_Tinkerer

    A-bit_Tinkerer MDL Junior Member

    Mar 24, 2014
    61
    45
    0
    Time zone shown in Date and Time after setup completed

    Thank you for your response.

    The updated install.wim is converted to an install.esd and then copied to a USB flash drive containing all of the other original Windows 8.1 Update iso files.

    Windows 8.1 Update is then installed to an empty Hard Disk Drive after booting from the USB flash drive.

    After the Windows 8.1 setup has completed, I check the time zone using the Date and Time applet, which shows the time zone is still Pacific Time. I tried to post an image of the Date and Time window, but I need to have 20 posts.
     
  4. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    8,102
    27,033
    270
    What about the first install screen (choosing lang, time...)? that's what really define the final later settings
    if you want to change that, you need to mount boot.wim/2 and set the desired time zone
     
  5. A-bit_Tinkerer

    A-bit_Tinkerer MDL Junior Member

    Mar 24, 2014
    61
    45
    0
    The 1st install screen for Windows Setup shows:

    Language to install: English (United States) <== the only language choice
    Time and currency format: English (United States) <== this is not a choice of time zones
    Keyboard or input method: US

    During the install, none of the custom Settings dialogs allow selecting the time zone.

    As suggested, I did change the default time zone for the boot.wim (index:2) to Eastern Standard Time using the command previously listed. I also kept the install.esd with the default time zone changed to Eastern Standard Time. After doing a new install as previously described and after setup is completed, the time zone shown in the Date and Time app is still Pacific Time.

    So changing the default time zone to Eastern Standard Time in both boot.wim (index:2) and install.esd did not work for changing the time zone from Pacific Time after Windows Setup is completed.

    Any suggestions on what to try next?
     
  6. Underclocked

    Underclocked MDL Member

    Sep 3, 2013
    243
    41
    10
  7. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    8,102
    27,033
    270
    #7 abbodi1406, Nov 18, 2014
    Last edited by a moderator: Apr 20, 2017
  8. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,544
    662
    60
    #8 Flipp3r, Nov 18, 2014
    Last edited by a moderator: Apr 20, 2017
    I always install a clean OS from WinPE using dism from a script. At the end I set the Locale:
    Code:
    ::========== SET LOCALE ====================================================================================================
    dism /Image:W:\ /set-syslocale:en-AU
    dism /Image:W:\ /set-userlocale:en-AU
    dism /Image:W:\ /set-inputlocale:en-AU
    dism /Image:W:\ /set-timezone:"AUS Eastern Standard Time"
    wpeutil reboot
    You could just mount & update your wim/esd's to make these defaults as well...
    I seem to recall the fallback language is still en-US...
     
  9. A-bit_Tinkerer

    A-bit_Tinkerer MDL Junior Member

    Mar 24, 2014
    61
    45
    0
    I created an autounattend.xml file using the code provided by abbodi1406 and put the file in the root of the USB flash drive. The time zone was still Pacific Time after the Windows 8.1 setup was completed. I did make sure the autounattend.xml was saved in UTF-8 format.

    I then discovered that the file name needed to be unattend.xml rather than autounattend.xml because of the <settings pass="specialize">.

    The time zone was then set to the desired Eastern Standard Time after the Windows 8.1 setup was completed.

    I have also found that there is a TZUTIL.EXE command that can be used to set the time zone. Using TZUTIL.EXE would allow setting the time zone in the setupcomplete.cmd. However, TZUTIL.EXE also changes the clock forward 3 hours (difference between PST and EST), which means that using TZUTIL.EXE is not a solution to changing the time zone AND having the correct clock time.

    So, my solution to having the desired time zone after Windows 8.1 setup is completed is to use the unattend.xml (as listed above) in the root of the USB flash drive.

    Thanks to everyone for their time, comments and assistance.