CrackTcpip.sys for Vista SP1 RC v668 (17052)

Discussion in 'Windows Vista' started by admin, Jan 7, 2008.

  1. admin

    admin Administrator
    Staff Member

    Apr 24, 2007
    229
    99
    10
    CrackTcpip.sys driver to patch half-open connection limit in Windows Vista SP1 RC v.668 with tcpip.sys version as 6.0.6001.17052.

    Detail at the blog.

    Note: CrackTcpip.sys for RTM version at post #14 at page 2.
     

    Attached Files:

  2. cracker60

    cracker60 MDL Novice

    Dec 30, 2007
    5
    0
    0
    If it replaces 0x0A by 0xFF, the maximum number of connexions isn't 255, it is unlimited :
    the instruction is cmp edx, 0Ah, the second operand is 8bit, but sign-extended to 32, so 0xFF means 0xFFFFFFFF
     
  3. sunfish

    sunfish MDL Junior Member

    Jun 10, 2007
    93
    5
    0
    Unless you're lookng at the source code, I don't think you know what you're talking.
     
  4. hanschke

    hanschke MDL Senior Member

    Jan 8, 2008
    404
    30
    10
    but not for x64 vista :(
     
  5. cracker60

    cracker60 MDL Novice

    Dec 30, 2007
    5
    0
    0
    The blogs says :
    At VA (not offset) 0x597222, you have the "cmp edx, 0Ah" instruction I talked about.
     
  6. Manugal

    Manugal MDL Novice

    Jan 12, 2008
    2
    0
    0
    But if I run Vista with F8 and select Disable Integrity Check, it does work?
     
  7. Manugal

    Manugal MDL Novice

    Jan 12, 2008
    2
    0
    0
    Nothing, it doesn't work :(

    With the new Microsoft tcpip.sys Patch it updates that file at 6.0.6000.16567 version. With the old TCP/IP AutoPatcher 1.5 can I toggle limit?
     
  8. PrEzi

    PrEzi MDL Addicted

    Aug 23, 2007
    534
    3
    30
    It doesn't work with SP1 v744.
    It loads the drivers OK (says the service is running), but still gives
    the EVID4226 errors in event viewer :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. MrBeer

    MrBeer MDL Member

    May 23, 2007
    156
    4
    10
    It doesn't work with SP1 v744

    I can second that Still getting error on 744
     
  10. Peggie

    Peggie MDL Novice

    Oct 24, 2007
    1
    0
    0
    Yep ive used it on ultimate 64 and i couldnt even boot into safe mode afterwards.
    Had to do a startup repair with the vista cd.
     
  11. grayfox

    grayfox MDL Novice

    May 19, 2007
    12
    0
    0
    I did something like this once but had backed up the file. Using a bootCD I can recover without too much trouble.
     
  12. admin

    admin Administrator
    Staff Member

    Apr 24, 2007
    229
    99
    10
    Would you mind trying this?

    This is the new version of CrackTcpip.sys for v744 and 6001.18000 (RTM). Details here.
     

    Attached Files:

  13. voodoosau

    voodoosau MDL Novice

    Jan 27, 2008
    1
    0
    0

    thx,
    works great on a german vistax86 with this sp1-version!

    keep up that fantastic work please.

    greetz from germany

    voodoo
     
  14. xboy

    xboy MDL Novice

    Jan 27, 2008
    1
    0
    0
    Anyone got this to work on Vista SP1 x64? (17128)
     
  15. Star1ck

    Star1ck MDL Novice

    Jan 12, 2008
    4
    0
    0
    Has established SP1 on 32 bit version, 4226 has appeared again, the version of the file 6.0.6001.18000, a new problem))))
     
  16. dannsd

    dannsd MDL Novice

    Jan 8, 2008
    6
    0
    0
    Yeah, I became impatient and tried it out after I posted. Luckily I had setup a restore point before hand. The uninstall did not work properly and I could not restore my internet on vista x64
     
  17. ace518

    ace518 MDL Novice

    Feb 2, 2008
    1
    0
    0
    I will test

    I am using vista x64 with SP1 and am willing to try any new version of the patch you got.
     
  18. Jent

    Jent MDL Novice

    Feb 2, 2008
    2
    0
    0
    #20 Jent, Feb 2, 2008
    Last edited by a moderator: Jul 29, 2008
    Phew, I'm getting REALLY frustrated with this Windows Vista ****. My problem is following:

    I am using Linksys WUSB54GC Wireless Network adapter. First of all Linksys didn't have any Vista x64 drivers available, but I was able to find functioning drivers made my mr_smith or something like that. Now I'm facing serious problems with this TCP "syn_sent but syn_ack not received" problem. Thing is that _almost_ every (lets say 1 out of 2) 4226 event appears in Vista event log, but Internet dies! It says connection is limited. If I try to disable the adapter, network sharing center dies and I have to kill it. After that I am also unable to shutdown (it hold to "shutting down" -phase). If I reboot without trying to disable network adapter it reboots nicely and Internet works again.

    Ok, well, I have tried atleast 4 different kind of hacks to go-around this TCP issue. but EVERYTIME I patch the connection limit and restart to normal mode (have to do this in safe mode), it tells "service or group dependency was unable to start" (or something like that). I am unable to start DHCP, Firewall or any network service from control panel -> services. When I reboot to safe mode and unpatch, everything works again.

    So basically so far I have two options: To face the problem with 4226 almost every day and reboot everytime it appears and my Internet dies or to downgrade to Windows XP, which I really would not like to do.

    If someone comes up with a solution and visits Finland anytime, I'll offer him or her a beer, I promise!

    I have Windows Vista x64 ultimate unless that was clear already.