Dell 1546 no boot or display

Discussion in 'PC Hardware' started by logicwatch, Jun 1, 2012.

  1. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    Hi
    Trying without success to fix a friends Dell 1546 laptop however am pretty sure its the main board that has gone !
    symptoms :
    switches on ok
    but no splash screen no bios detail etc screen just blank (tried external vga as well no display )
    fan starts up for a few seconds
    power light goes off after 10 seconds

    attempted the following
    stripped down to main board then re-seated processor
    removed bios battery left out over night then fitted new one
    re thermal pasted processor

    I suspect failure of mainboard probably GPU as no display hence shutdown after 10 seconds, with fan starting up I guess cpu ok as instruction given to start fan then shutdown system due to hardware failure , no video output?
    I guess probably not economical to repair as a new board too costly.
     
  2. nintenpc

    nintenpc MDL Novice

    Dec 12, 2011
    33
    6
    0
    Did you try reseating the RAM?

    Otherwise, sounds like you should try reflowing the motherboard. To reflow it, you'll want to strip any detachable parts off, scrape off any stickers, etc. that you can, prop it on a cookie sheet using tinfoil (meaning no metallic part of the board should touch anything, so use the tinfoil to raise it up), and bake it at about 385F for about 8 ish minutes. It sounds ridiculous, and it is definitely a last resort, but I've seen it work.
     
  3. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    yes re seated ram , baking it sounds a bit drastic ! found a company in london who say can fix the board to component level will possibly give it a try ??
     
  4. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    tested with new ram same fault
    thanks anyway ;)
     
  5. logicwatch

    logicwatch MDL Member

    Jan 26, 2011
    247
    22
    10
    sent motherboard away to re ball gpu now all working again :biggrin:
     
  6. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,356
    1,446
    180
    reball is the proper way.. however u could have used a $20 heat gun to resolder it yourself for 3 minutes time.