Dell D520, how's running win7?

Discussion in 'Windows 7' started by regtm, Dec 4, 2010.

  1. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    I need opinions and expiriances regarding use of win7 on a Dell D520 laptop.
    Is it working ok,
    are all the drivers installed by windows update,
    how is the performace,

    I want a laptop that can run 7 with no problems, and at the moment I have few models to choose from, with D520 being the newer of them, and also dual core, so I am thinking if 7 will be a good run on it.
    Beside D520, on the list are: IBM ThinkPad R52 and T41, HP NC8000.
    I dont need ultra performance for gaming, only for some light programs like text, pictures, internet browsing...
    Thanks
     
  2. pebbly

    pebbly MDL Novice

    Nov 13, 2010
    5
    3
    0
    I'm running 7 ultimate on an I5100 only problem I have is with the ATI Radeon mobility 7000 64mb it will not run aero ,but apart from that every thing is OK and no probs with drivers etc .
     
  3. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    It is not mine jet, but the specs are:
    Core Duo T2300 1,66G
    1x512mb ddr2 (i will pit 2x1gb later when (if) I buy it)
    60gb SATA,
    WiFi,
    dvdcombo

    All drivers ok with win 7 windows update?
    What about SLIC and offline act?
    Thanks
     
  4. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    Canouna,
    Why use DAZ loader, if I flash the slic modded BIOS??
     
  5. waverider

    waverider MDL Novice

    Sep 2, 2009
    2
    0
    0
    I've been running W7 on a D520 (T2300 and 2GB memory) since August 2009 and it runs just fine for the sort of applications you have in mind. All drivers are from the W7 installation. The only problem I have is that the Windows 7 Bluetooth driver doesn't work with Delll's BT350 Bluetooth module, but the Toshiba ones work if you need Bluetooth. Other than that, I haven't looked back since upgrading from XP!
     
  6. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    Thanks Waverider!
     
  7. pebbly

    pebbly MDL Novice

    Nov 13, 2010
    5
    3
    0
    thanks canouna, yes I have tried the catalyst and wddm drivers and forced aero with no luck , It's no hardship
     
  8. sonomazr2

    sonomazr2 MDL Novice

    Oct 28, 2009
    26
    3
    0
    I am running Win7 and dual booting Mint on a Dell D520.
     
  9. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    Thanks for letting me know.
     
  10. gollumcaprio

    gollumcaprio MDL Novice

    Dec 6, 2010
    3
    0
    0
    My DELL Latitude D520 is having nagging faults
    *McAfee has seemingly removed itself
    *Keep getting a popup message from taskbar saying low disk space despite running disk cleanup and removing programs
    *Windows Audio Service wont start on its own despite being on auto, so every startup I have to start the windows audio service and I just shouldnt have to do that, I didnt have to before
    *My network connection signal drops constantly, and when it does, Im not able to repair it, I get a message: problem registering with DNS
    *Although this problem isnt as significant as the others, my theme persistently changes to windows classic and then it instantly changes back to normal for some strange reason.
     
  11. regtm

    regtm MDL Novice

    Dec 2, 2010
    17
    0
    0
    @ gollumcaprio
    Hm, it looks like a software problems. You should try with fresh copy of windows. You using w7? Have you done slic mod/offline acivation?