Dell E1505 - Installing Win7 HELP!!!

Discussion in 'Windows 7' started by techman28, Jul 31, 2009.

  1. techman28

    techman28 MDL Novice

    Jul 26, 2009
    40
    0
    0
    I have been trying to setup win7 on my dell inspiron e1505 laptop and I get past the install stage but when it starts up and I try to install the laptops drivers, then I have a problem. I start by installing the graphics card driver and then the touchpad driver and somewhere when installling those, after whenever I try to restart the laptop, I always get the blue error screen. It sucks.

    Does anyone here have a dell e1505 and have installed win7 on it? How did it go, did you have any problems with installing the drivers?

    Anyone have any advice for me?

    Anything?

    Thanks in advance for any and all help.
     
  2. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    57
    60
    I have a Dell D630 laptop which is a the 965 express chipset, and no problems here. I only install the Graphics Drivers from Intel, the Chipset Drivers from Intel, and the SATA/AHCI drivers from Intel. I don't use any Dell drivers because of them not being needed/wanted or not working right.

    You shouldn't need any other drivers than those.
     
  3. shakeyplace

    shakeyplace MDL Addicted

    May 5, 2007
    861
    75
    30
    I ran the RC on my e1505 (6400) fine, just getting back and downloading the final now, I will let you know... What display drivers are you installing?
     
  4. techman28

    techman28 MDL Novice

    Jul 26, 2009
    40
    0
    0
    I ended up figuring it out. It was my own stupid fault. I had downloaded the win XP drivers and tried to install them, I then downloaded the correct vista drivers and they worked perfectly with win7.

    Thanks for everyones help/ input.
     
  5. Philbo

    Philbo MDL Novice

    Oct 18, 2010
    1
    0
    0
    I also have a Dell E1505 laptop and had no problem installing and running Windows 7. However, my laptop began having battery charging problems and I checked the Internet for such symptoms. It seems this problem is fairly prevalent, not only with the Dells, but with other machines as well. I've changed the battery, the A/C adapter, re-installed drivers, including BIOS to no avail. It runs fine with the A/C adaptor plugged in, saying "Plugged in, not charging". The batter power level remains constant as long as the A/C adaptor remains plugged in.
     
  6. ozzyboy

    ozzyboy MDL Member

    May 18, 2009
    163
    5
    10
    #6 ozzyboy, Oct 19, 2010
    Last edited: Oct 19, 2010
    I also have 1505 and without any problemes, with installing or drivers...
    I encountered problems with 1501 wich has no card reader driver support, even after windows update!!!

    edit:
    1505 has diagnostic tools to check the hardware... use this tools to see who couse the probem
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Coasie

    Coasie MDL Junior Member

    Feb 7, 2009
    80
    12
    0
    The only problem I have with my E1505 and Win7 is the non-existent bluetooth driver.
     
  8. shakeyplace

    shakeyplace MDL Addicted

    May 5, 2007
    861
    75
    30
    My bluetooth works fine (Dell 355 Bluetooth), everything works fine... try windows update for most drivers
     
  9. shakeyplace

    shakeyplace MDL Addicted

    May 5, 2007
    861
    75
    30
    Most card readers have support, for instance, I use card reader driver from newer Dell or even Toshiba for my card reader, what type does the 1501 have?
     
  10. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    Given the original post is over 4 years old I'd imagine this problem has long since been solved or it's just no longer relevant somehow.
     
  11. oldsh_t

    oldsh_t MDL Expert

    Dec 23, 2009
    1,027
    494
    60
    OR were just spaming here!!
     
  12. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    Yep.......