Disable all vmware logs

Discussion in 'Virtualization' started by DeityLizard, Apr 4, 2019.

  1. DeityLizard

    DeityLizard MDL Novice

    Jun 30, 2013
    5
    0
    0
    #1 DeityLizard, Apr 4, 2019
    Last edited: Apr 4, 2019
    Does anyone know a way to disable the VMware logs created in C:\Windows\Temp\vmware-SYSTEM and C:\Users\<username>\AppData\Local\Temp\vmware-<username>

    I added logging = "FALSE" to the config.ini file in "C:\ProgramData\VMware\VMware Workstation" but that only disables the logs in the virtual machine folders.

    Edit: I'm running VMware Workstation 15 Pro (version 15.0.4) on Windows 10 Pro 1809 (host PC)
     
  2. Leif Targo

    Leif Targo MDL Novice

    Oct 26, 2009
    45
    21
    0
    hmmm, just a note: i never edit config.ini, but the *.vmx file in every VM folder and input the line there.

    logging = "FALSE"
    ...
    another option is to redirect logs in a different folder like c:\temp in *.vmx
     
  3. DeityLizard

    DeityLizard MDL Novice

    Jun 30, 2013
    5
    0
    0

    Logging = "FALSE" in .vmx file disables logging for a single virtual machine.
    Logging = "FALSE" in "C:\ProgramData\VMware\VMware Workstation\config.ini" disables logging for ALL virtual machines.
    Logging = "FALSE" does NOT disable the logs in "C:\Windows\Temp\vmware-SYSTEM" and "C:\Users\<username>\AppData\Local\Temp\vmware-<username>"

    I don't want to redirect the logs to another folder. I already tried redirecting them to null but I could not get that to work in Windows.
     
  4. Leif Targo

    Leif Targo MDL Novice

    Oct 26, 2009
    45
    21
    0
    Check the settings for a single VM (found this in VMware forum 2016):
    a) Gather debug information = none
    b) enable the option (sounds funny, that enable means off): Log virtual machine progress periodically

    both does not work, because the two log files are created just when Workstations 15.x (vmware.exe) starts...
    -so no solution yet-
     

    Attached Files:

  5. grrgrr

    grrgrr MDL Member

    Oct 4, 2017
    186
    153
    10
  6. Leif Targo

    Leif Targo MDL Novice

    Oct 26, 2009
    45
    21
    0
    > Hope this helps. No, see note #3:
    Logging = "FALSE" does NOT disable the logs in "C:\Windows\Temp\vmware-SYSTEM"

    so a Workaround is to redirect the logfile to the temp folder with
    log.filename = c:\temp\vmlog.log
    and empty the temp folder with a batch file. But even if VMware Workstation
    is not running, the VMware services are active and doesnt allow to remove the folder vmware-SYSTEM.