Disable Homegroup

Discussion in 'Windows 8' started by expert, Apr 6, 2014.

  1. expert

    expert MDL Junior Member

    Nov 3, 2007
    74
    84
    0
    Disable Homegroup

    Run : gpedit.msc

    Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Homegroup
    double click: Prevent the computer from joining a homegroup , select Enabled and then click OK.
     
  2. amsk98

    amsk98 MDL Junior Member

    Sep 8, 2013
    56
    5
    0
    this one tips help full for me

    thanks.
     
  3. NiFu

    NiFu MDL Member

    Jun 29, 2013
    129
    133
    10
    Doesn't work in "Windows 8 Core" because of "group police editor" not available.

    My alternative:

    • Right mouse click on "Homegroup" in Windows Explorer
    • "Change HomeGroup settings" -> "leave HomeGroup"
    • Open "Local services"
    • Stop service "HomeGroup Listener" and "HomeGroup Provider"
    • Disable service "HomeGroup Listener" and "HomeGroup Provider"
     
  4. ian82

    ian82 MDL Expert

    Mar 7, 2012
    1,147
    302
    60
    There are many methods out there on the web for removing the annoying Home Group icon which is not desired if you don't use the Home Group feature. Here is a method that actually works:


    1) Open Computer and right-click on "Homegroup" icon present in Navigation pane and select “Change Home Group Settings
    Now click on "Leave the homegroup..." link given at bottom. (it will ask, and you need to confirm it)

    2) Press CTRL + R then type services.msc

    3) Double Click on Home Group Listener then set its status to Disabled

    4) Double Click on Home Group Provider then set its status to Disabled

    5) Press CTRL + R then type regedit

    6) Navigate to:
    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\E xplorer\Desktop\NameSpace\

    7) Find a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} , this is the registry entry Home Group icon.

    8) Delete the folder from the registry.

    9) Restart your computer
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Reznov

    Reznov MDL Novice

    May 17, 2012
    36
    16
    0
    I believe those must be "Win" instead of "Ctrl".
     
  6. Enigma256

    Enigma256 MDL Senior Member

    Jan 17, 2011
    354
    300
    10
    Just disabling (and stopping) the two HomeGroup services is enough. There is absolutely no reason whatsoever to go delete the namespace entry in the registry. Doing so would make undoing this more difficult and could have other unforeseen consequences. Reboot is also unnecessary.