Disabling Auto Play in Group Policy Editor does nothing

Discussion in 'Windows 10' started by Phoenix, Aug 17, 2015.

  1. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    458
    60
    This has been the same also on Windows 7/8/ and now 10

    When I install the OS, the first thing I do is to disable Auto Play then head over to Group Policy Editor under Administrative Templates and disable Auto Play from there as well.

    After installing PowerDVD 15 Ultra, I would notice that Auto Play has been enabled so how was it able to override the Group Policy settings?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    did you apply the group policies with gpupdate? I use xpAntispy to disabled autoplay, it just works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. timster

    timster MDL Senior Member

    Aug 23, 2009
    465
    344
    10
    #3 timster, Aug 17, 2015
    Last edited: Aug 17, 2015
    I disabled Autoplay in the Settings app.

    I'll grab a copy of PowerDVD 15 Ultra and try and repro what you've described

    edit:: Autoplay was not re-enabled after I installed PowerDVD 15 Ultra
     
  4. Drexl

    Drexl MDL Junior Member

    Aug 9, 2007
    59
    7
    0
    This is probably a stupid question, but did you do it correctly? In the GP editor, in "Turn off Autoplay," I think you need to Enable it, and then in the box on the lower left it will have a menu where you choose what kinds of drives you want to turn it off on. (Select "all drives.")

    There's also a "Set the default behavior for Autorun" which works the same way. Select Enabled, and then in the menu "Do not execute any autorun commands."
     
  5. pf100

    pf100 MDL Addicted

    Oct 22, 2010
    735
    582
    30
    Control Panel > Autoplay, set all to "take no action" fixed it for me. Group policy editor didn't seem to do the trick for me either.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    458
    60
    yeah man the All Drives option is the default option and I did set it to enabled. Give it a few reboots and Auto Play is reenabled.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...