[DISCUSSION] Windows 10 Final Build 19041/2/3/4 (PC) [20H1/2 / 21H1/2 vb_release]

Discussion in 'Windows 10' started by Enthousiast, Dec 10, 2019.

  1. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    We'll see when the next release preview updates are released, already announced by @abbodi1406

    as said mixed results on real hardware, on vmware and vbox all couldn't boot 22000.434 ot 19044.1466 when setup as UEFI.

    Not updating the ISO boot files bootx64.efi and efisys.bin seems to have solved it for now.

    22533.1001 doesn't show this behavior so it probably is a glitch with the .434 and .1466 set of updates.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. aleross

    aleross MDL Novice

    Apr 4, 2015
    28
    6
    0
    Does anyone have the

    es-mx_windows_10_enterprise_ltsc_2021_x64_dvd_f6aaf384.iso
    es-mx_windows_10_enterprise_ltsc_2021_x86_dvd_93a5debe.iso

    files for download or links to download those version?

    The versions for Mexico
     
  3. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    13,147
    64,376
    340
    It's caused by the updated efisys.bin (EFI boot code)
    the updated script/config is to skip using updated boot files

    if UUP is already downloaded, just replace the new files
     
  4. Coody

    Coody MDL Novice

    Aug 16, 2012
    7
    0
    0

    Sorry for my question, but will you update the script on uup-dump.net?
     
  5. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Muggaen

    Muggaen MDL Senior Member

    Dec 30, 2011
    445
    187
    10
    V76 isnt released yet so I dont think its updated on uup-dump yet.
     
  7. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    13,147
    64,376
    340
    I'm still debating about the default state of the new option SkipBootFiles
    should it be ON or OFF?

    waiting the new RP updates (for 2000 and 19041) soon to see if it fix the EFI issue
    if it's fixed, then i guess the default state should be OFF
     
  9. shhnedo

    shhnedo MDL Expert

    Mar 20, 2011
    1,148
    1,563
    60
    Ok. I was quick to judge. There is indeed a problem, it happened on a Dell laptop in UEFI mode - storage drives are "missing" in the windows installer. Sad story. MSFT need to pull their rested sh*t together. Not even gonna bother with January updates altogether.

    AND YES, I KNOW ABBODI MADE A WORKAROUND.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Coody

    Coody MDL Novice

    Aug 16, 2012
    7
    0
    0
    sorry for my bad english...

    how you say, waiting is the best way... it's funny how much we want new builds :rolleyes:, i know... you're doing a great job!:worthy:

    what is Microsoft doing... it's a bug or something new?

    i searched everywhere and i don't find anything proper about the efi boot change
     
  11. SM03

    SM03 MDL Expert

    Dec 16, 2012
    1,115
    537
    60
    yes, I exactly did that as I wrote here, just replaced the two files ConvertConfig.ini & ConvertConfig.cmd in my existing v1466 UUPD folder & made another ISO
    Tested & that's booting into the UEFI environment like earlier, thanks.
     
  12. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. sonic9

    sonic9 MDL Member

    Aug 4, 2009
    104
    43
    10
    corrupted efisys.bin in Jan2022 has problem only in efi boot AND iso (vmware/vbox/hyperv and ventoy because it read iso)
    real hardware with burned disc in efi boot will not work too (not tested, but if someone want contradict, find burner & disc)

    rufus (or usb/hdd fat32 boot efi part) works because it doesn't need efisys.bin.
     
  15. sonic9

    sonic9 MDL Member

    Aug 4, 2009
    104
    43
    10
    @shhnedo For your "Drivers missing problem", is laptop 11th/12th Intel ? some oem configure sata controller as Intel rst or raid vsm instead ahci.
     
  16. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    38,863
    68,070
    450
    The problem is that it needs to work for all possible tools and people not having to be dependent on a specific third party tool, personally i only use my ever working FAT32 formatted 8GB USB key.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    13,147
    64,376
    340