Dism not working correctly?

Discussion in 'Windows 7' started by Elmer BeFuddled, Jul 18, 2013.

  1. Elmer BeFuddled

    Elmer BeFuddled MDL Novice

    Jun 11, 2010
    17
    2
    0
    When I run DISM, I can mount an image, save and unmount the image, but trying to inject updates and the trial keys fails, whereas they've always worked before.

    Yet I can add the updates if using WinToolKit.

    I recently did a repair install, possibly the last as I think two years means about time to start over again.

    I'm just wondering if the repair installmay have "broken" something that is staring me in the face but I cannot see it for looking!

    Oh, Win 7 Pro 64bit.
    TIA
     
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    Maybe it would be better to use imagex instead of dism?! Imagex is used on Windows 7 while dism on Windows 8!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. NICK@NUMBER11

    NICK@NUMBER11 MDL Expert

    Mar 23, 2010
    1,354
    632
    60
    before you did a repair install, did yo have installed Windows AIK installed?

    if so re-install that and try again
     
  4. Elmer BeFuddled

    Elmer BeFuddled MDL Novice

    Jun 11, 2010
    17
    2
    0
    #4 Elmer BeFuddled, Jul 19, 2013
    Last edited: Jul 19, 2013
    (OP)
    Think you've almost hit it on the head, between you. The repair install was doing some daft things to me so I did a completely fresh install. For some reason I couldn't change the screen res from 800x600. So on a whim and with nothing to lose, I installed a Macrium Reflect image onto my C: drive.What surprised me for a start was that it installed everything as it was. I always thought the likes of Macrium just do a "super system restore".

    Anyhow, I've managed to drop the keys in with a batch script that calls for dism.exe and this time I noticed it was using v6.1.7600.16385.

    I can only think that maybe the disme.exe that lives some where in Windows Kits\8.0\version 6.2.9200.16384 was being used and is not compatible with 7? Or I was getting a conflict? Thing is my X17-24395 image (iso) contains a dism version 6.1.7601.17514, as does the X17-59465 image (iso).

    A possibly related issue was when July's MRT.exe M$ update download was a double one due to 'newer model', the version went from 4.1 to 5.2 and the release date jumped back to June. Are we guinea pigs again?

    Since that update everyone of my normal restore points is apparently "corrupted" and therefore un-usable. Along with other odd things happening, hence the repair install attempt.

    Gotta love M$ for finding me things to do I didn't realise I wanted to do!!

    Thanks to both for answers. You made me look a little deeper at things.