Does anyone experience constant explorer crashing for builds 9879+?

Discussion in 'Windows 10' started by JJJohan, Dec 10, 2014.

Tags:
  1. JJJohan

    JJJohan MDL Novice

    Feb 7, 2010
    14
    0
    0
    #1 JJJohan, Dec 10, 2014
    Last edited: Dec 11, 2014
    I Google'd over and over on this issue for some time now hoping I'd find someone mentioning this, but to my surprise no one has, which 99% of the time means I've done something dumb and I'm at fault for installing something sus. However this is re-occurring, clean install after clean install, not on one but on two physical machines.

    The only mention I could find is that people have had their explorer crash once every so often, some as "often" as every half hour - which was supposedly fixed with a fairly recent Windows 10 update delivered via WU. This did not fix my issues though.

    Ever since upgrading to build 9879 (and since then, 9888 - literally just for the proof of concept hoping it would resolve the crashes somewhere in the internal changes) my explorer.exe crashes. As soon as Windows starts, it will crash. As soon as it automatically restarts Explorer, it'll crash again - to the point I have to start my programs using the task manager.

    Having said that, I can still start File Explorer instances (i.e. starting explorer.exe with an argument so it opens the file path) which won't start up the taskbar/desktop and thus not crash.

    I have found a painful "workaround", which is to "upgrade" my 9888 build, which takes around half an hour - upon which it'll work until I uninstall or install any program.

    Things I have tried so far:
    - SFC /scannow - offline as well
    - DISM /restorehealth offline variations
    - Disabling ALL shell extensions using a portable utility
    - Starting in safe mode with zero startup options
    - Startup repair
    - Removing as much as I can from Programs and Features that I don't absolutely need
    - Different graphics drivers, at the most off-chance DWM is failing (one machine has AMD, the other NVidia hardware)
    - Crying myself to sleep
    - The 9860 explorer.exe from Heidegger's link below

    I'm really just curious as to wonder if I'm really the only person experiencing this problem because it seems odd to re-occur so often and on two completely separate physical machines. If you guys think I have missed any obvious information or think I missed some simple repair steps please do let me know - happy to provide a explorer.exe crash dump as well but it is definitely crashing within Windows, not loading a third party DLL (tracing it with WINDBG).
     
  2. WildByDesign

    WildByDesign MDL Addicted

    Sep 8, 2013
    670
    321
    30
    I have not had any explorer.exe crashes during my thorough testing of all builds thus far. And this has been everyday use. I have experienced the GDI leak though and simply restart explorer before it reaches 10,000. Did you install the explorer crash patch that was released recently for 9879? It was supposed to resolve it. But unfortunately there are no patches available for 9888 since it isn't supported. You would probably be best off getting back onto the supported Insider builds.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Heidegger

    Heidegger MDL Member

    Mar 17, 2008
    136
    51
    10
  4. JJJohan

    JJJohan MDL Novice

    Feb 7, 2010
    14
    0
    0
    I know that is the case for most people, maybe it's my particular software configuration. I have also installed the patch without any luck. Back to my environment:

    - Visual Studio 2013 (thinking it was this at first, I tried the 2015 preview on another clean install)
    - Office 2013 Pro Plus
    - 7-Zip
    - Google Chrome
    - Notepad++
    - Skype
    - Spotify
    - Citrix Receiver
    - Steam + other games

    On my work laptop (Yep, preview OS - Judge me harshly :))
    - All of the above excluding games
    - Navisworks Simulate 2014
    - Dropbox
    - SQL Server 2014 Express
    - RAD Studio (Basically Visual Studio but for Delphi)

    I've tried removing Skype, Citrix Receiver, Chrome, 7-Zip and Notepad++ with no luck. Office and Visual Studio are my bare minimum though.

    Thanks, I forgot to add that to the list - I have tried this as well.
     
  5. MS_User

    MS_User MDL Guru

    Nov 30, 2014
    2,770
    452
    90
    sounds like corruption....i recommend clean install to 9888