Does Windows 10 Preview require PAE, NX, and SSE2

Discussion in 'Windows 10' started by buggatti, Oct 1, 2014.

  1. buggatti

    buggatti MDL Novice

    Nov 17, 2012
    18
    0
    0
    If not,can i bypass this requirement in the preview. Is yes, How

    Planning to install in my Mom old pc when i go there on the weekend. She has a Pentium 4 GHz dont know the model .


    Thanks
     
  2. Wazoo

    Wazoo MDL Senior Member

    Nov 5, 2013
    416
    199
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mmmirkec

    mmmirkec MDL Novice

    Jul 3, 2013
    20
    4
    0
    #3 mmmirkec, Oct 1, 2014
    Last edited: Oct 2, 2014
    Yes u need PAE, NX, SSE2 and windows 8 Patches v1.5 does not work.Old computers need Jan again:)

    Untitled1.png
     
  4. stealth50k

    stealth50k MDL Novice

    Oct 3, 2014
    1
    0
    0
    #4 stealth50k, Oct 3, 2014
    Last edited: Oct 3, 2014
    I need this bypass also for windows 10 x64. X2 toledo 3800 AMD 939. It can run windows 8.0 but not 8.1 and 10. 10 gives an error 0x000005d. Its stupid how these special cpu instructions are required and not even shown on the minimum requirements. They shouldn't require them. It should be enabled when its available. Shouldn't hinder the operating system from installing or booting. Just ridiculous. If anyone knows how to bypass these checks please post how.

    I got 4GB of ram with x2 processor 64 bit. This computer is still alive and well. Fully capable machine. Runs good in 8.0 x64 but i want to upgrade to 10 already.
     
  5. Wazoo

    Wazoo MDL Senior Member

    Nov 5, 2013
    416
    199
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. arseny92

    arseny92 MDL Secret Weapon

    Sep 22, 2009
    570
    1,253
    30
    Additionally to PAE, NX and SSE2, the CPU must support CMPXCHG16b, PrefetchW and LAHF/SAHF to install Windows Technical Preview. This was outlined on the TechNet download page, as an elaboration to the statement saying that a small subset of x64 CPUs capable to run Windows 8.1 won't be able to run the preview.
     
  7. moderate

    moderate MDL Guru

    Aug 31, 2009
    2,595
    2,107
    90
    #7 moderate, Oct 3, 2014
    Last edited: Oct 3, 2014
    I think you are putting together x32 requirements (PAE, NX and SSE2) and x64 ones (CMPXCHG16b, PrefetchW and LAHF/SAHF)...
    All x64 CPUs already have PAE, NX and SSE2 by design...

    ...also all of CMPXCHG16b, PrefetchW and LAHF/SAHF were already required by W8-1-x x64.

    I think there are NO new requirements...
     
  8. moderate

    moderate MDL Guru

    Aug 31, 2009
    2,595
    2,107
    90
    They just compared to W8-0...
     
  9. 40musa40

    40musa40 MDL Novice

    Apr 12, 2014
    6
    0
    0
    hello to my computer setup windows 10 can not be installed
    p4 processor pentium windows 8 windows patches do not work please help wonder what happens if windows 10 patches Does Produce please help immediately or Does it help me if you have another program to create the link , please:confused:o_O:(:weeping::weeping::weeping::weeping::weeping::weeping:
     
  10. Wazoo

    Wazoo MDL Senior Member

    Nov 5, 2013
    416
    199
    10
    There is NO method at this time that patches Windows 10 TP to run on P4 processors.
    If you are having problems patching for Windows 8/8.1 then go here ... http://forums.mydigitallife.net/thr...e-Patch-(Bypass-Windows-8-CPU-feature-checks) ... and post what problem you are having.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. alealex401

    alealex401 MDL Novice

    Aug 16, 2013
    5
    0
    0
    I've done,patched like 8.1 ...

    Only problem on boot whit error for ntoskrnl ,anyway F8,7 and ok.

    See the attachment...
     

    Attached Files:

  12. Wazoo

    Wazoo MDL Senior Member

    Nov 5, 2013
    416
    199
    10
    Excellent result. Others have tried and failed to patch Windows 10 TP.
    But even when patching Windows 8/8.1 it doesn't always work.
    So it may work but not in all cases.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. alealex401

    alealex401 MDL Novice

    Aug 16, 2013
    5
    0
    0
    Thank you, commodore...
     
  14. mmmirkec

    mmmirkec MDL Novice

    Jul 3, 2013
    20
    4
    0
    which patch you used?
     
  15. squeeky

    squeeky MDL Novice

    Oct 14, 2010
    4
    0
    0
    Which patches did you apply from the patcher ? I just get an error about ntoskrnl.exe because its not signed. Wont boot with F8 or F7. I applied Remove SSE2 and NX and hal.dll and halmacpi.dll

    Got errors for all others
     
  16. alealex401

    alealex401 MDL Novice

    Aug 16, 2013
    5
    0
    0
    The same last patch for 8.1.
    I got the errors too but anyway i did install.

    And this after patch "bcdedit /set {default} NoIntegrityChecks Yes"

    And whit bellavista (bcd editor) select more option and "disable recovery sequence".

    That last was the problem for me!
     
  17. mmmirkec

    mmmirkec MDL Novice

    Jul 3, 2013
    20
    4
    0
    Can you upload your patched files :confused:
     
  18. squeeky

    squeeky MDL Novice

    Oct 14, 2010
    4
    0
    0
    I did
    Remove PAE Check
    Remove SSE2 and NX check
    Fix hyperthreading in hal.dll
    Fix hyperthreading in halmacpi.dll
    Remove winload patchguard x86

    run: bcdedit /set {default} NoIntegrityChecks Yes

    Wont boot. Technical Preview x86
     
  19. alealex401

    alealex401 MDL Novice

    Aug 16, 2013
    5
    0
    0
    what Error give to you?