Driver Signing changes in Windows 10, version 1607

Discussion in 'Windows 10' started by yomoma2, Aug 10, 2016.

  1. yomoma2

    yomoma2 MDL Member

    Feb 27, 2010
    218
    48
    10
  2. squalles

    squalles MDL Novice

    Jul 28, 2016
    10
    0
    0
    all fine to me... i make a clean install with 14393 build and my last driver to x-fi titanium are beta and installed normally... installed nvidia 369.09 modded inf by quadro drivers without problems too
     
  3. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,316
    120
    Clearly something changed.

    I tried to install my VGA card on server 2016 using a modded inf (the stock inf blocks it on anything but desktop installations) and it worked after the usual



    But was impossible to install a very common atheros driver, which was correctly signed.

    I solved that specific problem using the driver bundled with W10, but clearly thees new requirements will be a pain on some HW.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. yomoma2

    yomoma2 MDL Member

    Feb 27, 2010
    218
    48
    10
  5. pf100

    pf100 MDL Addicted

    Oct 22, 2010
    852
    829
    30
    This is ridiculous. I don't like where this is heading (IDLWTIH). I say this so much I should abbreviate it to IDLWTIH.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. WardocsRevenge

    WardocsRevenge MDL Expert

    Jan 13, 2012
    1,776
    590
    60
    16.8.1 installed perfect on a clean install of windows 10 lstb 2016 no issues with any drivers
     
  7. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,316
    120

    What that does mean?

    Obviously you don't have any problem, with all the drivers bundled with the installation, available on WU, and from the major vendors like AMD or Nvidia.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. WardocsRevenge

    WardocsRevenge MDL Expert

    Jan 13, 2012
    1,776
    590
    60
    i download all my drivers i remove anything WU installs
     
  9. Velocet

    Velocet MDL Novice

    Sep 27, 2013
    2
    0
    0
    Tried to install Intel XTU (Extreme Tuning Utility) which uses a kernel driver that is correctly signed by Intel but it won't install. This sucks big time but i didn't tried any other self signed drivers for my Roland products. Maybe someone wants to try the self signed drivers from Win-Raid?