dumb question about NUM Lock.

Discussion in 'Windows 8' started by maxb2000, Sep 28, 2014.

  1. maxb2000

    maxb2000 MDL Member

    Aug 5, 2012
    201
    48
    10
    Hi,

    I have Windows 8.1 installed in UEFI Mode with Ultra Fast Boot enabled (GPU supports GOP Driver) and secure boot.

    The problem is that the NUM Lock function is disabled everytime I restart the PC. How can I make it to stay enabled after reboot or shutdown ?

    In UEFI meniu is enabled the option that says: Bootup NUMLock state - > enabled.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Mr Jinje

    Mr Jinje MDL Expert

    Aug 19, 2009
    1,773
    1,088
    60
    #2 Mr Jinje, Sep 28, 2014
    Last edited by a moderator: Apr 20, 2017
    Try these

    Code:
    Function Set_NUMLOCK_Enabled {
    
    Set-ItemProperty -Path 'registry::HKEY_CURRENT_USER\Control Panel\Keyboard' -Name InitialKeyboardIndicators -Value 2147483650
    
    }
    
    Function Set_NUMLOCK_Disabled {
    
    Set-ItemProperty -Path 'registry::HKEY_CURRENT_USER\Control Panel\Keyboard' -Name InitialKeyboardIndicators -Value 2147483648
    
    }