ECS K7S5A SLIC 2.1/ACPI Problem

Discussion in 'BIOS Mods' started by Obelix, Dec 21, 2009.

  1. Obelix

    Obelix MDL Junior Member

    Oct 2, 2008
    78
    3
    0
    Hi,

    i can not successfully mod the ECS K7S5A PCB 1.1 Bios (here). I used amitool142 and do a ssv2 mod, but it dosn't activate Windows. The SLIC can not be detected by the SLIC_Tool, too.

    I can not include a rw everything report, because everytime ich click on "ACPI" the rweverything application crashes. I included a hwdirect dump from FFFC0000h Range: 40000h.

    It seems, that the ACPI Informations are not loaded.

    Can anyone help? Any Slic 2.1 would be Ok. (Asus prefered)

    Thanks!!
    Obelix
     

    Attached Files:

  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,475
    340
    The problem is as expected. The RSDT points to an FFh bytes area. This makes rwe to crash when reading the acpi tables.
    The SLIC injection does not work when injected to offset 10h, it was lost at flash procedure.
    Could you please upload your flashtool?

    We have to try for different SLIC address. The tool alows to manually choose....I'll reply later to make some suggestions. You can mod yourself then...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Obelix

    Obelix MDL Junior Member

    Oct 2, 2008
    78
    3
    0
    Thanks Yen.

    I use aminf342.

    Obelix
     

    Attached Files:

  4. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,475
    340
    OK, only way to get a working mod is to insert the SLIC into BBL!
    Kocoman had got the same problem and it worked!

    How to mod:
    Use ASUS SLIC2.1, SSv2. At advanced options: Manual location for SLIC insertion: 3F500, tick allow SLIC in bootblock.

    To flash the mod:
    aminf342 filename.rom /b

    (/b to flash bootblock, is a higher risk)



    If it shouldn't work, try a new mod, but tick use alternate method ADDITIONALLY. (Same settings as above)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Obelix

    Obelix MDL Junior Member

    Oct 2, 2008
    78
    3
    0
    Yen, you are great!!! It works!!! I didn't need to use the alternate method.

    THANK YOU VERY MUCH!!!

    Obelix
     
  6. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    10,938
    10,475
    340
    Enjoy it! :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. kocoman

    kocoman MDL Senior Member

    May 16, 2007
    328
    4
    10
    I was trying to search my own post when me and andyp figured this out, but the post was gone (because of the upgrade to vBulletin 4)?

    anyway I have another AMD ECS board and this method works too.

    one problem with ECS boards is they all have USB or USB add in PCI card problems... has anyone experience it?
     
  8. braille12

    braille12 MDL Novice

    Sep 17, 2010
    3
    0
    0
    mine works.....ECS G31T-M...with ECS slic 2.1 and certificate....using SSV3
     
  9. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,210
    14,767
    340
    From where do u get an ECS cert?? :confused:

    Can u pls share with us?? (Hmm.. 3 months old post :p)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    i noticed the advent brand uses a lot of ECS.. check their laptops out for cert ripping.
     
  11. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,210
    14,767
    340
    Thanks for ur concern... but Advent has its own set of SLIC+Cert ;)

    Also in India, it is hard to find an Advent product :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...