Emachines T5212 with EFI wont flash with modded bios

Discussion in 'BIOS Mods' started by Simbalage22, Jan 25, 2011.

  1. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    I am trying to mod a Emachines T5212 with EFI. The Phonex tool does the mod, but when I try and upload it fails saying the bios versions are the same and therefor cannot continue. Using the recovery jumper works with the original bios, but loops trying the modded file.. any ideas?

    Emachine T5212 thanks in advance, Many thanks for all contributions on these tookls.

    link to my modded file
    http://www.mediafire.com/?222cfffy9qpf5d3

    Ps: the machine isnt bricked.. I just tried recovery because the 2 files are the same this cannot be done with windows, or IFlash.. So I am lost. Why does recovery work with untocuhed bios, but not with the modded one? also what are my optons to force iflash to use this file?
     
  2. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    tried the oa2intel tool in dos with the following error. This board cannot be modded?

    INT 15h EF01h failed to return EFI Variable Size -- FAILURE
    AH = 86h - NOT_SUPPORTED
    This tool is not authorized to update this BIOS.
     
  3. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    No One? Here is the original bios http://www.megaupload.com/?d=0XE2E5RS


    I have tried everything.. Uniflash, Dumping the bios, and the phoneix auto tool. It will mod it, but cant get the pc to take the modded file.. I even did recovery and it will load up the untoouched bios, but not the modded one.. Is this their way of stopping bios mods on efi?>
     
  4. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    I thought the intel tool only adds SLP, not SLIC? from what I understand, the intel tool is pretty useless these days

    you're using winphlash to try to flash this right? you need to go into the advanced settings and uncheck both "flash only if bios version is different" and "flash only if bios version is newer than system"
     
  5. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    #5 Simbalage22, Feb 4, 2011
    Last edited: Feb 4, 2011
    (OP)
    Thanks for the reply. Its IFlash. The bios modded with the phoenix tool, but will not take with IFlash... Errors out in windows and dos says the versions are the same therefor it cannot continue



    Tried Phoenix flash. will not work with efi.
     
  6. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    #6 Simbalage22, Feb 5, 2011
    Last edited: Feb 5, 2011
    (OP)
    Ok, I found another intel bios that supposidly works. I downgraded and tried.. it loaded but either wont flash after adding slic info. Iflash will not allow the flash to go, but the original untouched will with no problem. The only way the Phoenix tool will work is dynamic. All others Methods fail. Here is the RW file and the untouched bios, As well as some screen shots. Appears it already has a 2.0 slic thus why its not working


    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]


    Here is the bios and RWreport
    http://www.megaupload.com/?d=PQ5CXFLD


    I gave up a slic'd pc to figure this one out :) Thanks in advance as I dont see why the tool fails..
     
  7. Simbalage22

    Simbalage22 MDL Member

    Jul 27, 2008
    173
    5
    10
    Anyone? I recently lost all my data due to a drive failure. I am waiting for a replacement pcb so I can hopefully recovery.. But in the meantime I will keep an eye on this forum