Euro Truck Simulator 2 Stutters even with GTX 750Ti

Discussion in 'Gaming' started by avi smile, Oct 20, 2015.

  1. avi smile

    avi smile MDL Junior Member

    Mar 1, 2015
    94
    55
    10
    hi there
    i have a Intel Haswell Core i5 4430 @3.00GHz

    with 8.00 GB ram

    with a NVIDIA GeForce GTX 750 Ti

    and still when i play Euro Truck Simulator 2 the game stutters

    what is the problem? :confused:o_O

    thanks in advance
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Maverade

    Maverade MDL Novice

    Sep 15, 2015
    3
    1
    0
    Hey avi smile!

    Your hardware should be able to smash that the game.
    Usually this can be caused by a couple of things:
    Autosave,
    Any mods that are installed,
    A need to update your GPU's Drivers,
    Settings such as AA and/or any Nvidia CP AA,
    Among other things!
    Hope this helps!

    Maverade
     
  3. avi smile

    avi smile MDL Junior Member

    Mar 1, 2015
    94
    55
    10

    thanks
    well how could a know what is causing the problems

    1. how do i disable autosaves
    2. how do i check what mods are installed?
    3. my drivers are uptodate (maybe the last one isn't installed not more)
    4. how do i set these "Settings such as AA and/or any Nvidia CP AA,"

    thanks in advance
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,485
    1,321
    60
    You have VSYNC turned on, right? :D
     
  5. avi smile

    avi smile MDL Junior Member

    Mar 1, 2015
    94
    55
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,485
    1,321
    60
    Dude, it's in the settings menu... As well as every other thing people have mentioned. Pause the game > Settings > Graphics/Video Options. Turn on VSYNC and turn down/off any AA (Anti Alisasing is jagged edge smoothing), see how you go.
     
  7. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,725
    3,743
    180
    Agreed with that, apart from the vSync, if the card is not able to hit FPS @monitor Hz (Probably 60), then the FPS will jump around even more, and likely get locked to 30, which will cause even more stuttering

    I'd try what The Dev suggested graphics wise, but I'd turn off vSync for now until you find the sweet spot for getting a constant 60fps, or whatever your monitors refresh rate is
     
  8. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,485
    1,321
    60
    From what I've heard, this game has two versions of AA. One standard and one from NVIDIA. I may be wrong. But if both are enabled it could cause stutter.
     
  9. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,725
    3,743
    180
    If it does, then definitely, AA on it's own is hard work for any GPU, let alone mixing two different types

    IIRC, the game has a scaling option, which allows you to basically set downsampling, 100% is normal rez, shown at normal rez, 200% is double the rez downsampled to normal rez, and kills performance dead unless you have something like a 980Ti SLI setup
     
  10. avi smile

    avi smile MDL Junior Member

    Mar 1, 2015
    94
    55
    10
    update: nothing seems to work i tried changing the settings as written above but it seems to get worse and worse :weep: what could be the problem?:worthy:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...