Facing file sharing issue over network in windows 10 1803

Discussion in 'Windows 10' started by aladdin2006, Aug 10, 2018.

  1. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    Hi,

    How do I share files or folders or the contents of entire local drive to other people on network with authentication (Without file sharing wizard in folder options) like we used to do in Windows XP? When following the same procedure, it says 'Access Denied' while connecting from other network computers. I have enabled SMBv1 for sharing with WinXP. Normal simple file sharing is working fine on all network computers.

    Suppose, a computer running latest version of Windows 10 and its local drive(s) may be shared in such a way that only people who have password of this computer can access its entire drives (Without file sharing wizard in folder options) like we used to do in Windows XP.

    Please help to resolve issue.
     
  2. lynloz_83

    lynloz_83 MDL Novice

    Jan 31, 2012
    17
    17
    0
    Try this:


    Net Share "Files"="D:\Files" /grant:everyone,Full /UNLIMITED /Cache:Automatic

    "Files" = Share name
    "D:\Files" = Folder Location
     
  3. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
  4. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,842
    2,021
    210
    You need to configure your Network properly! Start with that on your Router, give the computer('s) which will have shared content fixed IP's first. Set the drive or the folders which will have the shared content to be accessible by user('s) or even to anybody by assigning the needed permissions. Allow the access to that shared content/Drive via the Firewall as well. That is needed in Windows 10.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    Perhaps you didn't read my post clearly. If network configuration was improper then normal or simple file sharing wouldn't work in the first place but as I said it's working fine on all OS and on all computers. The only issue is with authenticated drive sharing.
     
  6. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
  7. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,842
    2,021
    210
    Sharing, whatever kind of File-/Data-Sharing is used, is simply part of the Network Configuration!

    And the Network Configuration works closely with the Security Configuration as well.

    If you have some Firewall App running on your machines which having shared content, that also need to be configured properly as well. Windows automatically setup a Firewall while being installed too. You could disable the Windows Firewall and not use any other alike App, it is just dangerous not to use those. But that's simply up to the User and/or Owner of the used Devices.

    And I would never use shared data on any of my machines without security protection and that includes Usernames and Passwords for anyone who would get access. All of that is under the roof of Network Configuration.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    Tried your instructions by turning off windows firewall but no gain. The problem still persists. There's no any other security app installed but only windows defender. Right now I'm only concerned with this issue, not some sort of security about data.
     
  9. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,842
    2,021
    210
    Allowing or blocking some connection to any of your machines, you could use the Mac Addresses of those others to either allow or deny the access.

    I didn't tell to off the Firewall, I told to configure correctly! You need to allow or deny access from sudden devices in the firewalls config, separately in each of the computers you're allowing to use Data from. That config differs from App to App. You'll have to check the appropriate way for the App you're using.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. ch4os

    ch4os MDL Junior Member

    Jan 9, 2010
    72
    77
    0
    If you want to use admin shares like /d$/, you have to disable UAC remote restrictions since Windows 7. That‘s what is happening here most likely.

    Try this:
    • add the user you‘re trying to connect with to group administrators
    • create a new .reg file with this content:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "LocalAccountTokenFilterPolicy"=dword:00000001
    • run that file and import the registry setting
    • reboot

    That should work ;)
     
  11. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    please clarify how to do this. Win10 user is James; WinXP user is ed1. I want to share d$ of james on ed1's computer with login. Please clarify your instructions more so I can do this. Where is group administrator?
     
  12. ch4os

    ch4os MDL Junior Member

    Jan 9, 2010
    72
    77
    0
    #13 ch4os, Aug 12, 2018
    Last edited: Aug 12, 2018
    Well, in that case make sure user James is an administrator on your Win10 machine. This is already the case for the default user.

    If James is not the default user and you need to change it from standard to admin user, then there's different ways to do this:

    Easiest way:
    • Win+I (settings app) -> Accounts -> Family (and other people)
    • click on user "James" -> Change account type
    • choose "Administrator"
    The old fashioned way:
    • right click start menu -> Computer management
    • System tools -> Local Users and Groups -> Users
    • double click "James" -> Member of
    • Add -> Advanced -> Find Now
    • double click "Adminstrators" -> OK -> OK
    Both ways James is now a member of the administrators group.

    Also make sure you have enabled "password protected sharing" or you won't get a dialog to login with a different user. You can change this here:
    • right click network icon in systray area (bottom right)
    • "Open Network & Internet settings" -> Sharing options
    • "All networks" -> "Password protected sharing" -> "Turn on password protected sharing"
    • Save changes
    Give it a try, should work ;)
     
  13. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    There is one more option above password protected sharing which is 128-bit encryption or 40-bit. Which one to choose?
     
  14. ch4os

    ch4os MDL Junior Member

    Jan 9, 2010
    72
    77
    0
    Don't know about WinXP. I would try 128-bit first. In case it's not working you could lower that to 40-bit, but I wouldn't recommend that.
     
  15. aladdin2006

    aladdin2006 MDL Junior Member

    Feb 28, 2013
    72
    6
    0
    Many thanks to @ch4os

    It finally worked. There are actually two methods for doing this. One is share the drive with password protected sharing option and the other is disable UAC remote restriction. Sharing the entire drive may have problems while setting permission to all of the contents in case there are uncountable files and folders; so choose the other option in that case.

    I request admin to close this thread.
    Thanks.
     
  16. ch4os

    ch4os MDL Junior Member

    Jan 9, 2010
    72
    77
    0
    Glad I could help. You're welcome :)