Fixing failing WU/Store for a specific package

Discussion in 'Windows 10' started by toyo, Jan 10, 2019.

  1. toyo

    toyo MDL Member

    Aug 14, 2009
    214
    107
    10
    Hello guys,

    I'm in need of a WU/dism magician, if possible. I got bored and wanted to try the new DCH drivers for the Intel iGPU to test if what's some sort of GPU passthrough is working (cable in motherboard, selecting high perf. GPU for an app and having the discrete GPU render while the iGPU outputs. Seems to work nicely).

    However, there's an Intel related update failing almost each day and it's getting on my nerves. I wanna know if it's possible to install it (or remove it, even better) manually. The update fails with and without the driver package, with and without the iGPU enabled in BIOS. I tried to remove the packages with:

    Remove-AppxPackage -AllUsers -package "AppUp.IntelMediaSDKDFP_8.0.68.0_x64__8j3eq9eme6ctt"
    Remove-AppxPackage -AllUsers -package "AppUp.IntelMediaSDKDFP_8.0.68.0_x86__8j3eq9eme6ctt"

    But WU (or the Store?) brought them back after 1-2 days.

    I tried (after uninstalling the driver properly, of course) looking through Tasks, registry, just to find and eliminate the leftover entries related to these packages, still didn't work.

    This is how it fails:

    Installation Failure: Windows failed to install the following update with error 0x80070057: 9NCGJX5QLP9M-AppUp.IntelMediaSDKDFP.
    Installation Failure: Windows failed to install the following update with error 0x80246013: 9NCGJX5QLP9M-AppUp.IntelMediaSDKDFP.

    The app itself is hidden in Store, can't find it.

    O, and if I uninstall the driver, these app packages are left there, and while I can manually remove them in Powershell, WU brings them back when it updates other apps. Or at least this is what I have observed.

    So, is there any way to either manually find this package and install? Or much better, disable the iGPU, uninstall the driver, and stop Store/Wu from trying to update this thing that it shouldn't even be there anymore?

    Thanks.