Flash gone very wrong

Discussion in 'BIOS Mods' started by stephan288, Apr 14, 2012.

  1. stephan288

    stephan288 MDL Novice

    Aug 12, 2010
    3
    1
    0
    Hello wizards of Mydigitallife!

    I need a miracle. I modded and flashed hundreds of bioses during my time as computer-technician. never failed me before since I always check in your forum and double-check my result. but today something went very wrong.

    I have a HP pavillion p6100la from a customer here and it comes with vista. The MoBo is a MSI MS-7525 ver.1.0.
    so i downloaded the bios from HP website for this model.
    and extracted the BOS5.22 file, opened it with AWARD SLIC Mod v.1.35 and it gave me as Manufacturer COMPAQ. I changed it to HP, SLIC file HP.bin, SLP file HP.txt. Then i did verify with COMPAQHP-HPQOEM-2.1.XRM-MS in ISA mode and got error. so i repeated it with SSV3 and got error again, as well as in dynamic. When i tried 0+2 method it said that the slic successfully had been created. Then i made a bootable USB stick, copied the new slic bios file and AWDFlash but it hang, si i tried another version of Awardflash, also it didn´t flash. Then I committed the mother of all crimes, I know you will tell me that i am crazy. I flashed with WINFLASH, and actually it finished without error. But after rebooting i don´t get that blue HP screen, it shows me all the details of the pc, memory, cpu, disksbut then it goes to a black screen and just the white curser blinking, nothing more, keyboard blocked.
    I can´t go into bios with F10, can´t go into boot menu with ESC. it says it goes into bios and boot menu, but it jumps straight to the black screen with the curser.
    I tried using the awart recovery method with the bootable floppy, awardflash and the original bios file, but without any luck.

    Can anyone of you magicians perform a miracle and help me out? I will upload the modded bios i made, maybe you can find out what went wrong. there might be hope, since i get the post screen.

    Thanks for any help you can offer me and i promise i will NEVER EVER flash under windows again.

    Stephan
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,370
    15,015
    340
    Seems that the board doesn't brick... well try to clear cmos, remove the battery for a while, load default setup, try another USB/PS2 keyboard.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. stephan288

    stephan288 MDL Novice

    Aug 12, 2010
    3
    1
    0
    Hi Tito!

    Thanks for the fast reply. Well, before I went home yesterday (2:30 am) I took out the cmos battery and put the jumper into the Clear CMOS position, coz I also thought about that posibility. now after reading your reply (6:45 am) I just put on the jumper into normal position, disconnected the SATA cables and the keyboard, plugged in the power cord and turned on the computer, without CMOS battery. Same as yesterday. I get POST info, CPU, Memory, Disk info. It says: default settings have been loaded due to BIOS update or checksum error. Press (F10) to enter SETUP. Otherwise allow the PC to continue. I used the PAUSE key and it pauses, so keyboard is responding. But after that it goes to the black screen and cursor blinking, no response from keyboard anymore, no error message.

    I read about the AWARD recovery procedure and was thinking: it says it uses the .bin format, but the original file is called BOS5.22. How about renaming the file BIOS.BIN or BOS5.bin? Do you think this might help? in AMI BIOS recover it says to press and hold ctrl+home key, is there such a combination to force the bios to boot from floppy?

    Thanks

    BTW: i get the "default settings have been loaded due to BIOS update or checksum error" every time i turn on the pc.
     
  4. openfly

    openfly MDL Member

    Oct 18, 2009
    108
    8
    10
    as I have experience, that the award mod tools has faulty for specific brand.
    means, sometimes, some of them needs to manual mods.
    I guess there isn't any way to recover from boot ROM sector via recovery disk or another way for your half dead motherboard.

    I guess this is desktop, not laptop. it have removable cmos chip 90%(not soldering)

    only ways is get replace same cmos chip from ebay or another way, or you can use hotflash cmos from another similar working motherboard.

    hope you well
     
  5. stephan288

    stephan288 MDL Novice

    Aug 12, 2010
    3
    1
    0
    well i fixed the problem with some help from tito. with all the luck in the world i found the exact twin of the board in my "junk". the board was dead and i changed it last week. it was from another HP model, but the exact same model and same HP part number. i switched the bios with the faulty one with my SMD soldering station and i got it running again. as a different HP model, but what the hack, it´s all the same crap.

    Thanks Tito for the help.
     
  6. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,370
    15,015
    340
    Now use latest version of Award Mod tool (1.52) to mod the bios & flash from DOS :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...