Force Flash Gigabyte Motherboard BIOS

Discussion in 'BIOS Mods' started by bigwophh, Mar 25, 2011.

  1. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    Hi All,

    I have been searching for days and cannot find a working solution to force a BIOS flash on a Gigabyte P55-UD6 motherboard.

    To make a long story short, the motherboard I have was an early sample and the BIOS ID differs from the shipping version. But the boards are identical and the shipping BIOS will work if I can get it flashed.

    Can someone help explain how to either:

    A) Modify the BIOS ID of the BIOS file

    or

    B) Force the board to accept a Flash of the shipping BIOS

    Thanks for any help. It's greatly appreciated.
     
  2. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    Yes. I've tried @Bios, SPIFlash, AWDFlash, WinFlash, etc. Even just tried a Flashrom LiveCD, and of course, it won't boot completely.

    Is there no Award BIOS editor that'll let me change the BIOS ID? If SLICs and be inserted and other mods made, the BIOS ID should be able to be changed, no?

    Or even better, so I don't have to mod future BIOS revisions, is there a third-party flash tool available that'll let me flash the board with the correct shipping BIOS?
     
  3. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    Anyone have an idea here?
     
  4. NoJuan999

    NoJuan999 Experienced SLIC Tool Operator

    Jul 31, 2009
    9,919
    1,930
    300
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    I have been. The lastest MODBIN that I can find doesn't open the file, CBROM doesn't do what's necessary, Awardmod says no BCPs. etc.

    Any other suggestions?
     
  6. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    I should add that if I try to edit the new BIOS with the "Award BIOS Editor 1.0", I get a couple of errors when opening the file, but I can see the fields that need editing. I edit them, save the modded BIOS, but when I go to flash it says it's a bad image. I think I'm an updated tool away from pulling this off.

    Hoping someone can help.
     
  7. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    #8 911medic, Mar 26, 2011
    Last edited: Mar 26, 2011
    Did you try dumping the bios? Is that what you are asking about modding the dumped bios or download? If not dump it and mod away..I think ID can be changed, I will have to look at it..

    Can you upload or link to the bios files you are using?

    At least the bios ID you need.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    I did try dumping the original BIOS and editing the fields in the new one to try to make them match, but still had no luck. Here's a link to the original BIOS and the newer one I'm trying to flash...

    h**p://hotfile.com/dl/111982419/725d06e/bios-files.zip.html

    Thanks for any help you can provide.
     
  9. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    I reall appreciate the help here, thank you very much. Unfortunately, it didn't work. Just tried to flash the new BIOS and it says the image is invalid.
     
  11. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    Wait, I take that back. I got the invalid image message using Q-Flash, but just tried @Bios and it completed the flash.

    But, the system won't boot properly now. Now sure what the deal is--that version should have worked. Any chance I could beg you to try the same mod to this BIOS?

    h**p://download.gigabyte.ru/bios/motherboard_bios_ga-p55-ud6-c_f11b.exe

    Thanks again.
     
  12. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    I will but you need to flash from DOS with FLASHSPI..it is the best way to get a good flash. I will try new one now..

    Did the ID update??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    Can't tell if the ID updated becuase the system won't boot completely. The screen comes on during post, then the system gets stuck in a restart loop. Just restored from the backup BIOS and tried to flash using FlashSPI and it says Bad Bios Image.
     
  14. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. bigwophh

    bigwophh MDL Novice

    Mar 25, 2011
    19
    1
    0
    They're coming from GB's website. Unfortunately, this latest one won't flash with FLASHSPI or @BIOS. It says either bad BIOS image or part number incorrect. Darn.

    If you're feeling generous, here's one last one to try and then I give up.

    h**p://download.gigabyte.ru/bios/motherboard_bios_ga-p55-ud6_f10.exe

    Just to make sure I've explained things clearly, I need this newer BIOS modded with the part number from the original one posted early.

    Thanks again. You rock.
     
  16. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    I will replace all instances of ID and date to see if that matters
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. 911medic

    911medic MDL Guru

    Aug 13, 2008
    5,778
    491
    180
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...