Game DVR (Bar) Stopped Working In LTSB?

Discussion in 'Windows 10' started by Dude Guyman, Jun 7, 2018.

?

How much wood would a Woodchuck chuck if a Woodchuck could chuck wood?

Poll closed Sep 5, 2018.
  1. Precisely 3lb 12oz.

    0 vote(s)
    0.0%
  2. Ancient Chinese secret, not telling!!1

    33.3%
  3. A Woodchuck would chuck all the wood a Woodchuck could chuck if a Woodchuck could chuck wood.

    66.7%
  1. Dude Guyman

    Dude Guyman MDL Junior Member

    Jun 20, 2017
    65
    46
    0
    Does anyone else know anything about the Game Bar/DVR in Windows 10 LTSB 14393.2273. Mine used to work fine, but I went to use it and it simply will not start anymore. The following registry setting keeps changing itself from "1" back to "0" every reboot (required for it to take effect):

    [HKEY_CURRENT_USER\System\GameConfigStore]
    "GameDVR_Enabled"=dword:00000001

    I'm wondering if it got disabled/broken in one of the updates. I don't use it often but it saves me from having to install and setup OBS or something that I hardly ever use so if it should still work, I'd just as soon it did.
     
  2. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,206
    4,662
    90
    Code:
    Reg add "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "1" /f >nul 2>&1
    Reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "1" /f >nul 2>&1
    Reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\GameDVR" /v "AllowGameDVR" /t REG_DWORD /d "1" /f >nul 2>&1
    reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "1" /f >NUL 2>&1
    Reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "1" /f >nul 2>&1
    Reg add "HKCU\Software\Microsoft\GameBar" /v "AutoGameModeEnabled" /t REG_DWORD /d "1" /f >nul 2>&1
    reg add "HKLM\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "1" /f >NUL 2>&1
    Reg add "HKLM\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "1" /f >nul 2>&1
    Reg add "HKLM\Software\Microsoft\GameBar" /v "AutoGameModeEnabled" /t REG_DWORD /d "1" /f >nul 2>&1
    Those should turn the feature back on.

    If you check those locations in the registry (before entering the above), they may be set to 0 (disabled) - or missing which is same as disabled, the reg add's above should enable its use again.

    Copy/paste into a Administrator CMD (or PShell).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Dude Guyman

    Dude Guyman MDL Junior Member

    Jun 20, 2017
    65
    46
    0
    Didn't work, but thanks for trying. Same as before [HKEY_CURRENT_USER\System\GameConfigStore] "GameDVR_Enabled"=dword:00000001 gets set to "1", I reboot and check and it is back to "0".
     
  4. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    2,206
    4,662
    90
    As you said may of been a update that changed how it works... :g:

    Cant put anything past m$ these days :(

    They give something then take it away the next month!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Dude Guyman

    Dude Guyman MDL Junior Member

    Jun 20, 2017
    65
    46
    0
    #5 Dude Guyman, Jun 8, 2018
    Last edited: Jun 9, 2018
    (OP)
    Yep, being LTSB, I didn't expect it would be there at all, but it was. Maybe MS decided they needed to "fix" that and remove it, because something is actively changing that registry setting back to zero every reboot no matter how many times I change it to one.

    Edit: I was do for a nice fresh install anyway so reinstalled WIN10 LTSB and updated directly to the latest build, same programs and settings, and now GameDVR works again. No idea...but at least it doesn't seem to have been deliberately disabled anyway.