Google chrome automatic update not working

Discussion in 'Windows 7' started by ashish1989, Apr 2, 2020.

  1. ashish1989

    ashish1989 MDL Member

    Sep 20, 2013
    161
    9
    10
  2. chillgates

    chillgates MDL Member

    Dec 15, 2010
    137
    56
    10
    Most probably your firewall blocked google update checking tool. Look in firewall app block settings or just turn off firewall and try updating chrome. If you are installing offline setup , there is no need to worry for update.
     
  3. ashish1989

    ashish1989 MDL Member

    Sep 20, 2013
    161
    9
    10
    Already done it also paused my antivirus too, but no progress
    I have seen a workaround of it on net, that copy the update folder from a working machine to your ones
    But I do not have any other machine on which I can find update folder of google chrome which is in program files x86
    If you have the same, can you provide me the update folder of chrome
     
  4. chillgates

    chillgates MDL Member

    Dec 15, 2010
    137
    56
    10
    #4 chillgates, Apr 2, 2020
    Last edited: Apr 2, 2020
    This is the update folder for chrome 64 bit Version 80.0.3987.162 , try it.. Let me know if it worked. I delete the link after few minutes.
     
  5. chillgates

    chillgates MDL Member

    Dec 15, 2010
    137
    56
    10
    something is blocking , may be hosts file or your registry
     
  6. ashish1989

    ashish1989 MDL Member

    Sep 20, 2013
    161
    9
    10
    How to identify it then
     
  7. chillgates

    chillgates MDL Member

    Dec 15, 2010
    137
    56
    10
    google forum says , uninstall chrome, reboot system and install it again. try it.
     
  8. ashish1989

    ashish1989 MDL Member

    Sep 20, 2013
    161
    9
    10
    already done many times
     
  9. windsman

    windsman MDL Expert

    Jan 11, 2010
    1,415
    1,203
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,313
    817
    90
    #14 kaljukass, Apr 2, 2020
    Last edited: Apr 3, 2020
    Deleted as not suitable post.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. ashish1989

    ashish1989 MDL Member

    Sep 20, 2013
    161
    9
    10
    I uninstalled it using revo uninstaller and deleted leftovers of it, after restart I manually deleted the chrome folders in program files x86 and in user local app data, cleared regitry with ccleaner and then installed again fresh
    However I will try to use .msi installer as recommended by you and will try to repair it if possible
     
  12. Tux 528

    Tux 528 MDL Novice

    Apr 20, 2020
    6
    2
    0
    #16 Tux 528, Apr 30, 2020
    Last edited: Apr 30, 2020
    Hi!
    I assume you have already tried the browser's built-in cleaning tool to solve this problem.
    It seems that, in most cases, installing Chrome (with administrator privileges) using the Standalone Installer works (Download link: google.com/intl/en/chrome/?standalone=1); you can also try to do it by restarting your computer into Safe Mode (this can be done by going to Windows Settings > Update and Security > Recovery > Advanced Startup > Restart Now, then select the Safe Mode option).
    Best regards